Unable to install CUDA toolkit in Jetson Xavier using SDK manager

Hi,

I constantly get the following error when i try to flash my Jetson AGX Xavier-

Access to APT repository and ability to install Debian packages with it.: Apt repository check failure (sudo apt-get update && sudo apt-get check).
command < ssh -t -F /dev/null -o PreferredAuthentications=password -o PubkeyAuthentication=no -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no -o ConnectTimeout=5 root123@192.168.55.1 “sudo timeout 200 apt-get update && sudo timeout 200 apt-get check” > terminated with error.

I do not know how to proceed further and i could not find a similar topic in the forum.

Thanks in advance.
Raj

Did you complete the first boot setup? Normally the flash takes place first in recovery mode, and when actual flash completes, then the unit reboots. Then the end user has to create an admin account login, and only then can it go on to installing items via apt (it uses ssh to the admin account, but if the account does not exist, or if the password has not been set up, then this will fail).

Additionally you need internet access. Without this apt can’t succeed.

Do keep in mind that you don’t have to flash every time, you can uncheck flash and just install CUDA if the Jetson is fully booted and has the ability for login via your admin account. Looks like you used name “root123”, and so the test is to see if your host PC (or local at the Jetson) can log in to that account over ssh.

Can you ssh to Jetson Xavier and run “sudo apt-get update && sudo apt-get check” in it to see if there is any error?

Yes, i have completed the first boot setup.
The user name is root123.
I can log in to Jetson Xavier over ssh

This is the error i get when i try to execute sudo apt-get update && sudo apt-get check

root123@root123-desktop:~$ sudo apt-get update && sudo apt-get check
[sudo] password for root123: 
Ign:1 https://repo.download.nvidia.com/jetson/common r32.5 InRelease
Ign:2 https://repo.download.nvidia.com/jetson/t194 r32.5 InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Err:4 https://repo.download.nvidia.com/jetson/common r32.5 Release             
  Could not handshake: Error in the pull function. [IP: 184.25.239.72 443]
Get:5 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease [88,7 kB]  
Err:6 https://repo.download.nvidia.com/jetson/t194 r32.5 Release               
  Could not handshake: Error in the pull function. [IP: 184.25.239.72 443]
Get:7 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease [74,6 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease [88,7 kB]
Get:9 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 DEP-11 Metadata [288 kB]
Get:10 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 DEP-11 Metadata [282 kB]
Get:11 http://ports.ubuntu.com/ubuntu-ports bionic-backports/universe arm64 DEP-11 Metadata [9.272 B]
Get:12 http://ports.ubuntu.com/ubuntu-ports bionic-security/main arm64 DEP-11 Metadata [42,3 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports bionic-security/universe arm64 DEP-11 Metadata [52,8 kB]
Reading package lists... Done                
E: The repository 'https://repo.download.nvidia.com/jetson/common r32.5 Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://repo.download.nvidia.com/jetson/t194 r32.5 Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

please remove the nvidia related source list from your /etc/apt/… and do the apt update again.

Thank you for your reply.

Earlier i found this solution

Remove source list

through the steps mentioned in the link, i was able to remove nvidia related source list.

I successfully completed the installation using SDK manager.

Thank you for the help!