Clueless question

I have an original AGX Xavier (the one with 16 GB RAM). I have been busy with other projects for a long time. I want to use it again for some basic CUDA signal processing work. Before becoming distracted, I had installed ONLY the L4T version and made a note to myself that the process used was:

Manually flashing Xavier with L4T

Power down - unplug.
Connect monitor, kbd, mouse, Ethernet to Xavier.
power on.
plug USB-C from Host into FRONT USB-C port.
press ‘recover’ button (middle) and ‘reset’ (most towards center).
release ‘reset’, 2 seconds later release ‘recover’.

Type:

cd ~/nvidia/nvidia_sdk/JetPack_4.3_Linux_P2888/Linux_for_Tegra
sudo ./flash.sh jetson-xavier mmcblk0p1
Unplug USB-C cable

When prompted:

press reset
System should boot normally.

I believe that this was the last version before it was made possible to update the system using Apt.
The system that I created to support the Xavier now gives errors when I use the SDK manager - even a new install - to retrieve updates, i.e.:

Access to APT repository and ability to install Debian packages with it.: Apt repository check failure (sudo -S apt-get update && sudo -S apt-get check).
[sudo] password for dave: E: The repository ‘http://repo.download.nvidia.com/jetson/x86_64/bionic r32.6.1 Release’ does not have a Release file.

I want to reflash the system with the current L4T image so that I can get rid of Ubuntu 18.04 on my work machine forever. I’m really sick of that beaver.

I also get a lot of errors any time I do an “apt update” for any reason, mostly relating to lack of support for arm64 packages (this is an Intel I7)

I know that this is an old moldy machine, but I can’t sort out how to do one last flash of the Xavier so that I can move on.

hello wittend,

could you please try remove the installation folder completely, and re-download the JetPack release image again via SDKManager?

I will do that. Thanks!

Dave

Sadly, no joy. I uninstalled everything that I could find to uninstall, particularly using the sdkMamager. After downloading the latest copy (and then letting it update itself to an even newer version (1.70.xxx?), I get much the same result:

SDK Manager is verifying system readiness to install.
Access to APT repository and ability to install Debian packages with it.

Access to APT repository and ability to install Debian packages with it.: Apt repository check failure (sudo -S apt-get update && sudo -S apt-get check).
[sudo] password for dave: E: The repository ‘http://repo.download.nvidia.com/jetson/x86_64/bionic r32.6.1 Release’ does not have a Release file.

I have no clue what a “Release file” might be in this context.

Dave

Hi wittend,

Please share below info:
$ cat /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
$ cat /etc/nv_tegra/release

Hi wittend,

Please share below info:
$ cat /etc/apt/sources.list.d/nvidia-l4t-apt-source.list
$ cat /etc/nv_tegra/release

I assume that you mean for me to share this output when these commands are run on the Xavier.
These files do not exist on the Host system.

Unfortunately, I cannot boot the Xavier at all anymore. It tries, but the early boot messages indicate some errors finding what may be mount points that it cannot find.
Then it gives up and reboots.
This goes on over and over.
I can see this when I have a monitor attached via HDMI.
When I try to attach a terminal via USB, the Host “dmesg --follow” just keeps saying “[21286.189467] usb 2-2-port2: config error”.

I can’t reflash using sdkmanager.
Attempting to check device availability from Host yeilds:

dave@dillo:~/Downloads/nvidia/Jetson_Linux/Linux_for_Tegra$ sudo ./nvautoflash.sh --print_boardid
[sudo] password for dave:
*** Checking ONLINE mode … OK.
*** Checking target board connection … 0 connections found.
*** Error: No Jetson device found.
dave@dillo:~/Downloads/nvidia/Jetson_Linux/Linux_for_Tegra$

Ubviously, “dave@dillo:~/Downloads/nvidia/Jetson_Linux/Linux_for_Tegra$ sudo ./nvautoflash.sh” doesn’t work either.

I really only care about getting the whole system to the lowest state where I have the current L4T and CUDA installed.
I’m not after any of the AI development tools at the moment.
I want to work on signalprocessing applications for the moment.

Dave

Hi wittend,

The commands are run on Xavier.
Are you connect type-C [J512] to USB cable on Xavier?
Before flash, please run ‘lsusb’ command on your host to make sure you can see the device into recovery mode.
Then run below command to flash by manually:
$ sudo ./flash.sh jetson-xavier mmcblk0p1

Carolyuu,

Yes, I am connected using the USB C connector on the front {40 pin connector) side of the Xavier.
No, ‘lsusb’ on the Host does not show the Xavier as a connected device, although it is physically plugged in.
I have done this:

$ sudo ./flash.sh jetson-xavier mmcblk0p1

and it fails.

The one thing that I have not tried is removing the 1 TB NVME Flash SSD that was in the Xavier when I flashed it most recently.
Is it possible that it is trying to boot from that?

Dave

Hi wittend,

Please plugin type-C to USB on J512 port.
And use below steps to put your Xavier into recovery mode:

  1. Connect the developer kit as described above. It must be powered off.
  2. Press and hold down the Force Recovery button.
  3. Press and hold down the Power button.
  4. Release both buttons.

Run ‘lsusb’ on your host device, you can see this message, it means your device into recovery mode success.
Bus <bbb> Device <ddd>: ID 0955: 7019 Nvidia Corp.

When your device into recovery mode success, you can run below command to flash:
Flash on EMMc:
$ sudo ./flash.sh jetson-xavier mmcblk0p1

Flash on NVMe:
$ sudo ./nvautoflash.sh --storage nvme0

Ok, I finally got the Xavier to be visible by connecting USB-C cable directly to a USB port on my host machine with no intervening hub.
THis is a fresh rip-out-and replace reinstall of the SDKManager.
I still get all of the errors I have encountered before no matter which approach I try.

Going through the SDKManager always gives me the error:

The repository ‘http://repo.download.nvidia.com/jetson/x86_64/bionic r32.6.1 Release’ does not have a Release file.

Installing manually always fails, no matter whether I try to install to eMMC or to NVME flash drive.I’m attaching output from attempts to flash to each media, plus other outputs.

After manually flashing, the Xavier displays tne NVIDIA logo and then proceeds to attempt to initialize in the usual Linux way. But it always presents a line that says (something like):

Trusty-boot panic. Rebooting in 5 seconds.

It does this over and over.

I have done everything that I can think of. I’ve added and removed lines containing ‘nvidia’ from the sources.list file. Deleted and reinstalled everything related to nvidia that I can find anywhere on the system, etc.

In desperation, I am including the ~/.nvsdkm/* tree in case it gives some clues.

home_slash_dot_nvsdkm.zip (785 KB)

Need to clarify, where are you running the “sdkmanager” command? Is that machine a x86_64 host?

I check your log, and none of them is related to jetson itself. The flash did not start. Sdkmanager directly failed when preparing the driver package on your host.

My point is your “apt-get update” seems has some problem from the beginning prior to all these installation.

For example, your host is trying to find “arm64” architecture. But we expect only amd64 arch here.

Err:52 Index of /ubuntu bionic-security/main arm64 Packages
404 Not Found [IP: 91.189.88.152 80]

Also, the rootfs is not there either. Are you sure sdkmanager has the permission to install anything to this path?

Info: change working directory to /home/dave/nvidia/nvidia_sdk/JetPack_4.5.1_Linux_JETSON_AGX_XAVIER/
Error: helper.Chdir with error chdir /home/dave/nvidia/nvidia_sdk/JetPack_4.5.1_Linux_JETSON_AGX_XAVIER/: no such file or directory

Please fix this on your host first.

WayneWWW,

I am running this from an Intel I7 Ubuntu Linux 18.04 machine and it has worked in the past.
I have wondered about the references to arm64 architecture myself. I do not know where they are coming from or how to fix them.

Dave

Google search may give your clue. Since this is your host, you should learn to find an answer for it.

Remove arm64 arch first and see if apt-get update can pass without error.