Unable to flash the AGX Xavier industrial with the carrier board

I have a carrier board from Connect Tech (Rogue) for Jetson AGX Xavier. I am a bit new to the new version of Jetpack packages. I had flashed the same board two years ago, but when I tried to change the boot configurations to boot from SD, I messed up the names and the board is not booting again. So now I have to flash it again. Frankly, I don’t remember how I flashed it a few years ago.


When I tried to install and use jetpack 4.6.2 directly, I get an error that SDK manager of 1.9.3 or higher is required.

When I try to install Jetpack 5.1.2, I don’t see the Xavier with carrier board, but rather the version with the Development kit.

After downloading the packages, Jetpack throws an Error saying " target depends on failed component".

I tried several time, but still no luck. I tried an older version 4.6.1, but Jetpack does not allow me to login, giving the error message “Authorization flow is now allowed.” I tried the oldest possible Jetpack 4.6.2, but the same result as the version 5.1.2.

The carrier board is connected via a Usb-c_USB3.0 cable to my laptop. An Internet Ethernet cable is also connected to the board.
By the way, I have an Ubuntu 22.04 which I realized still not supported with Jetpack, so I installed a fresh Ubuntu 18.04 next to the 22.04 one.

For any custom board, please do not use sdkmanager to flash. Check the vendor’s website and they shall provide their own driver package for you to flash…

1 Like

Oh, I totally missed it. Thanks!
So here I’ve got another problem. So I put this issue also here. It is not possible to install Jetpack 4.6.1 which is one of the requirements of installing the driver package of the custom board. Our algorithm has been tested and installed on the development board using Jetpack 4.6.1.

The installation guideline:


Nvidia says Jetpack 4.6.1 is compatible with Ubuntu 18.04, so why the SDK is asking for a upgraded version? “sdk manager version of 1.9.3 or higher is required”




It means your sdkmanger software is out of date. You can upgrade it first.

It has nothing to do with your “installation guide”. Sdkmanager is sdkmanager. Jetpack is jeptack.

Sdkmanager is just a tool to install jeptack. I am talking about the tool itself(sdkmanager) needs update. Not the jetpack needs update.

I understood your point. In order to install Jetpack 4.6.1 which is the prerequisite to install the driver package of the custom board, I need SDK manager. If I update the sdk manager, it does not include 4.6.1, but rather 4.6.2.
I am downloading the SDK Manager for Jetpack 4.6.1 from here:

So the question is: how can I install jetpack 4.6.1?

What version did you see with latest sdkmanager version ?

The jetpack version on the sdkmanager can be selected in case you don’t know. That is a scroll down bar.

please see the image in the previous message of mine. I just added it

please run your sdkmanager with this command.

sdkmanager --archivedversions

1 Like

wonderful! Thanks I missed this option when I was checking

sdkmanager --help

Thanks. Now I see the version 4.6.1. :)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.