Flashing Jetson Xavier AGX fail

I know this device is a bit long in the tooth now, but I wanted to clean all the rubbish i had installed on my machine and install a ‘clean slate’ to start some new projects. My host machine is running Ubuntu 22 so is reasonably up to date. Unfortunately, the only version of jetpack that seems to be compatible is 6.0.

The machine IS listed on the SDK manager GUI version, but not the CLI, so proceeded to successfully download all the files based on selecting this machine. On installation, it failed to install the Nsight dev stuff on the host which I really did not want anyway. Problem is that this stopped me flashing the Xavier as the whole proceedure ground to a halt. I seem to remember, the last time I used jetpack that many of the software installations could be disabled with a check box … but none exists for Nsight. Please … pretty please … could the devs add a check box for installing Nsight on the host machine for SDK manager 6.1 ??? Maybe also CUDA, as I dont need that on the host either.



If you are using SDK Manager, it’s tied to the Ubuntu version because of host packages.
Ubuntu 22.04 is only compatible with JetPack 6, and if you want to use JetPack 5, which is the latest version Xavier supports, you need 18.04/20.04.

Or download the BSP and flash manually to bypass such limitations:

Errrr … there are a few big holes in the docs …
eg. There’s nothing to tell me which Ubuntu version is compatible with jetson 6.0. I tried using 22.04 and it failed. Maybe it works with 20?

Also, upon running SDK manager 6.0 there’s a picture of Jetson Xavier AGX and options to click it so presumably it’s supposed to be compatible?

Much of it seems to be trial and error, so I’m now trying a fresh install of Ubuntu 20 on SD card on host and latest version of Jetson 6 … guess I keep trying diff permutations until it works :(

The compatible versions are clearly stated here:

OK, thanks, that’s very useful.
If my current attempt fails, I might try the BSP … are there any instructions? Is it like using a .ISO file?

Follow instructions here:
Files you should download:

1 Like

If anybody’s following this, the combination that eventually worked was Ubuntu 20.04.6 LTS (Focal Fossa) and Jetpack6.0 on the host for this machine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.