Cannot Flash Xavier with SDK Manager with JetPack 4.5.1


We used to flash Xavier AGX with Nvidia SDK manager, but we found that SDK manager cannot install Jetpack 4.5.1 (with Jetson OS 32.5) on Xavier properly.

BTW, we can install whole Jetpack 4.4 successfully. We’ve also tried to install Jetson OS 32.4 (in Jetpack 4.4) with other Jetson SDK Components in Jetpack 4.5.1 and it seems that everything can be installed properly.

Here’s the entire log when we meet the problem. (177.9 KB)

Thanks very much for helping.

Is your log from /home/covislab/.nvsdkm/logs/JetPack_4.5.1_Linux? I am not sure why I saw log from jetpack4.4 too.

Can you just choose OS and do not select any SDK at this moment and see if it can flash?

According to the log, it looks like even downloading the driver package to your host machine will fail.

Hi @WayneWWW ,

  1. I got the log by clicking the “export log” botton on SDK manager.
  2. I tried to install only Jetson OS 32.5 in JP 4.5.1 but it was not working. Here’s the log. (86.0 KB)
  3. If I select “download now, install later” checkbox in SDK manager, it can successfully finish downloading process.



According to the log, it says driver package is not able to get downloaded because your apt-get update on your host fails.

Please check if this is true.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.