Jetson AGX Xavier will not setup using SDK Manager and Jetpack 4.3

Hello Together,

I’ve previously setup my Jetson AGX Xavier using an Ubuntu 18.04 Virtual Machine and Jetpack 4.3. This worked well, and I worked with the Jetson for a while. Now I wanted to “reset” the Jetson, and read online the easiest method would be to flash it again with a clean version of Jetpack. This time I used an Ubuntu 18.04 Laptop and the 1.1.0 Version of the Nvidia SDK Manager. I’ve tried it multiple times, sometimes the whole download and installation ran through, mostly it stopped at some point, threw some errors in the logs, I hat to click retry, and finally it would say finished. But every time I connected it to a screen and tried to boot it up, it would get stuck at some point in the booting process. I was never able to use the Jetson since then. I attached the logfiles and a picture of the point where the Jetson startup screen stopped.
I’ve tried multiple ways, for example using an Ubuntu VM again, trying to flash Version 4.3 as well as 4.4 of Jetpack and deselecting all components to install on the Jetson except for the OS. Nothing worked so far. What I can also mention: I tried flashing it with the USB-C Cable connected from the host to the Jetson.

I hope I gave a good enough description of the topic.

Best Regards


VMs are “hit and miss” (mostly miss). VMs tend to lose USB since the Xavier will repeatedly disconnect and reconnect during flash, and the VM will not always pick up the Xavier on reconnect.