Can't flash Jetson AGX Xavier

I’ve completed the steps in SDK Manager up to “SDK Manager is about to flash your Jetson AGX Xavier”, but just can’t get past the flash step. I get this error:

Could not detect Nvidia Jetson device connected to USB. Verify that:

  1. is connected to this host machine with a USB cable.
  2. Jetson’s Ubuntu OS is up and running.
  3. Ubuntu ‘System configuration wizard’ is completed on the device.

The first two are done, but the third step isn’t. There’s no clue how to run the System configuration wizard. Can you tell me how to do this? (Also I’m running Ubuntu 18.04 as a virtual machine.)


Hi Alan,

There are two options to complete the missing step:

  1. Connect an HDMI cable, keyboard and mouse to the Xavier and turn it on. The system configuration wizard will start after boot.
  2. Follow this post to configure a default user and flash the filesystem again: Facing problem while flashing the eMMC on the Jetson Nano production ready module (not the Dev Kit)

Hi Miguel,

Thanks for the fast reply! I’ll try it.



I tried many times to flash the Xavier AGX but no luck at all at last two weeks. I have downloaded the image for offline installation. However the “flash jetson os” process is extremely slow after 90%. Until 99.8%, it would last more than hour before showing failure. I have captured the error messages. Please see any to have clue.

Are you using a VM?

Hi L,

Yes, I use virtualbox in Win10.

VMs do not handle USB correctly in most cases. During a flash USB disconnects and reconnects, but a VM tends to fail to detect the reconnect (perhaps the parent o/s is picking up the device). VMs are not officially supported, but you might get it to work if you find a way to always hand the recovery mode Jetson over to the VM without the parent o/s getting in the way. This is more the realm of the VM provider and isn’t under the control of the Jetson.

Many thanks linuxdev, I see if I can borrow old pc from friend and convert it to Linux. Then try my luck again.

Best Regards,

I struggled with VM for about one week and now gives up this workflow.

Now I tried the following “Poorman’s” workaround with my windows laptop. I borrowed a external usb3.0 docking + a blank Sata internal disk.

  1. Install an Ubuntu system on this externally docked disk.
  2. Reboot laptop and start with this Ubuntu.
  3. sdkmanager seems working with this setup.
  4. Certain trial-and-errors to complete the jetson OS flash for the first time.
1 Like

Great, I will try external sata with Ubuntu and see if I can make it work. Thanks!