AGX reflash Jetpack


I have the Nvidia Xavier AGX development kit. Recently we installed Jetpack and began working on the device. We had a substantial amount of errors so we decided to reflash Jetpack onto the device using the SDK manager as I had before (see procedure Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation). My question is this: how does reflashing the device differ from the intial OS flash? Are the procedures identical, putting into forced recover mode, making the necessary USB connections,etc?

Thanks for the help in advance.

If you flash with the same software release, then there is no difference between the first flash and the next flash. Flash will be with the correct USB port (USB-C) connected to the host PC, and the Xavier being in recovery mode.

Reflashed the OS. Went through the sdk manager process to completion. It said that everything was successfully installed. Then I restarted the Jetson and no HDMI output for the monitor. Which is strange because it was only after I restarted the device. I was able to use the Ubuntu configuration wizard and it gave output no problems up until that point. I tried different monitors, restarting the Jetson, etc. So I decided I’ll reflash the OS again to see. (This procedure has worked on RaspPi’s for me before). This time while going through the SDK manager, When it prompted me to use the Jetson to enter the Ubuntu config wizard, I wasnt able to because no output on the screen.

Try to use the headless method to do the same configuration as Ubuntu config wizard.

When xavier power on, keep the flash usb port connected with your host through type c cable, check if there is an interface /dev/ttyACM0 on your host. If there is, use minicom or any serial console tool to open it and check if you can configure the user account.

I guess the desktop may still not appear afterwards, but after this configuration, the UART console would be able to work so that you can help dump the dmesg for us.

FYI, there are many reasons why the system might be fully up and running, but video still fails. Try the serial console login (which is what the ttyACM0 comment from @WayneWWW is for).

Do beware that Jetsons have some restrictions on video modes, and that in part any monitor not using HDMI (such as using a VGA adapter) will fail. Monitors which are valid HDMI may not have a compatible mode. Serial console login is not only a way to complete first boot setup, it is also a way to view logs for video.

It turned out an adapter was indeed the source of the error. Thank you.