Unable to boot Jetson AGX Xavier

Approach #1: Flash using Etcher, Power On
Flashing succeeds, but device enters boot loop with NVIDIA splash screen

Approach #2: Boot into Force-Recovery Mode, Flash using SDK Manager 1.3.1.7110, Jetpack 4.4.1
Before flashing, I have verified the following on the host:
$ dmesg --follow
[ 1524.306286] usb 1-2: USB disconnect, device number 7
[ 1542.404230] usb 1-2: new high-speed USB device number 8 using xhci_hcd
[ 1542.637855] usb 1-2: New USB device found, idVendor=0955, idProduct=7019, bcdDevice= 1.02
[ 1542.637859] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1542.637861] usb 1-2: Product: APX
[ 1542.637863] usb 1-2: Manufacturer: NVIDIA Corp.

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 093a:2532 Pixart Imaging, Inc. 
Bus 003 Device 002: ID 258a:1006  
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 008: ID 0955:7019 NVidia Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

During flashing, I get the following error:
ERROR: Flash Jetson AGX Xavier 16GB/32GB: Board ID(2888) version(400) sku(0004) revision(L.0)

However, flashing appears to finish successfully:
12:22:04.625 - info: NV_L4T_FLASH_XAVIER_WITH_OS_IMAGE_COMP@JETSON_AGX_XAVIER: *** The target t186ref has been flashed successfully. ***

At this point, the device appears to exit Force-Recovery mode and try to reboot normally. It enters a boot loop with the NVIDIA splash screen again, and the host can’t connect to install packages.
12:23:08.433 - error: command error code: 1
12:23:08.434 - info: Event: - error code is: 1001
12:23:08.434 - warn: Failed to get component from group data map for
12:23:08.442 - error: Could not detect NVIDIA Jetson device connected to USB. Verify that:
1. The device is connected to this host machine with a USB cable.
2. Jetson’s Ubuntu OS is up and running.
3. Ubuntu ‘System configuration wizard’ is completed on the device.
This can be validated by running the ‘lsusb’ command on your host, and look for “0955:7019” (NVIDIA Corp).

Any idea what I should do here? I’ve been completely stuck for more than a day. I’ve tried using gtkterm, but since the device never really boots I don’t get anything useful. I’ve attached the full logs below:
SDKM_logs_JetPack_4.4.1_Linux_for_Jetson_AGX_Xavier_2020-11-17_12-18-17.zip (120.9 KB)

Thank you so much in advance for taking a look! Any advice would really be appreciated!