Flashing Jetson AGX Xavier with JetPack4.1 or using SDK Manager not working

I tried to flash the Jetson AGX Xavier I have but until now no success, I tried the JetPack tool and the SDK Manager (old and latest version) and still no success,

It is either stuck while flashing for hours or finishes the flashing, reboots, but gets stuck on the NVIDIA logo and doesn’t continue to start the full OS!

Modules manufactured in recent years may not work with old jetpack. You can try to flash jp4.6.4 and see if it can work.


I did try with previous version of the jetpack, and still no success!

I have similar behaviour; it is one of the following scenarios:

  • (1) From the terminal, everything seems to be working fine and the flashing of the device is done without any warning or error message, but the Xavier AGX doesn’t reboot properly

And it is stuck in the NVidia logo.

  • (2) While formatting the system is stuck at ~95% or 96% of the progress and nothing happen after (PS: I have left it running for almost a full day and still nothing)

What do you think is the issue with the device?

And do you have any service (technical hardware support in Europe) that can help me solve this issue if I send it to them?

Thank you!




Actually you should dump the serial console log from your board. We get every kind of “cannot boot” issue everyday and the reason behind them are all different.

It won’t be possible for us to directly say “hey it must be XXX is wrong” by just these comments from you.

Also, there is no evidence to show that it is hardware issue yet. Please dump the log first.


For which version of JetPack you want to have the log?

And how can I get the “log” saved and sent to you? (e.g., screenshot, or is there a feature I should enable)



  1. Jetpack5.1.3

  2. I already posted the link in previous comment, are you able to see? I don’t need screenshot. I need full log as text file. You could also check other flash issue post and see how other shared their logs.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.