AGX Xavier fail to complete the flashing using ./flash script as well as SDK manager for L4t 32.5.1 but works fine for jetson TX2

I am facing flashing issue. I have one TX2 device and xavier. I successfully flashed the TX2 device with 32.5.1 but Xavier always struck at this place. I tried even in SDK manager(struck at 99%). how to resolve this issue. I changed the USB cables also. Still the issue persists in the same place.

Attached the logs
SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_AGX_Xavier_2021-06-28_20-05-18.zip (244.1 KB)

hello sivashankar,

is this Jetson AGX Xavier ever flashed before?
could you please gather below information for reference,
for example,
please put Jetson AGX Xavier enter forced-recovery mode and check $ lsusb for the device number.
please share the complete logs with flash scripts, $ sudo ./flash.sh jetson-xavier mmcblk0p1
thanks

Hai JerryChang,

The device that listed for “lsusb” was 7019. I have exported the logs from the sdk manager after it get hanged at 99% Attached the logs in my previous chat. If you still need logs, i will send you.

This device already(2 months back) flashed with same JP 32.5.1 using ubuntu 18.04 64-bit OS which was success and booted. but now i tried now with 16.04 64-bit desktop host system which was failing in both sdk manager as well as flash script.

hello sivashankar,

there’re two Jetson AGX Xavier series with four-digit number, 7019.
it’s P2888-0001 for 16 GB memory and P2888-0004 for 32 GB memory.

the logs you shared is device stuck at tegrarcm_v2,

[  16.3266 ] 
[  16.3296 ] tegrarcm_v2 --boot recovery
[  16.3327 ] Applet version 01.00.0000
[  16.3533 ] 
[  17.3580 ] tegrarcm_v2 --isapplet

ubuntu-16.04 should works since I’m also used that to flash my Jetson AGX Xavier.
just would like to double confirm your status by running flash script to burn the board manually.
$ sudo ./flash.sh jetson-xavier mmcblk0p1

My device was 16GB. It struck at this place in my lot of flashing attempts either using sdk manager or by using above flash script. With the same host PC i did the flashing successfully for TX2 device before i attempted for AGX Xavier 16GB.

hello sivashankar,

please have a try with offline approach to assign the board info to the command-line.
for example,
$ sudo BOARDID=2888 BOARDSKU=0001 FAB=400 BOARDREV=H.0 ./flash.sh jetson-xavier mmcblk0p1

ok. I am going to perform below steps. Please confirm,
sudo tar -I lbzip2 -xpf Jetson_Linux_R32.5.1_aarch64.tbz2
sync

cd Linux_for_Tegra/rootfs/
sudo tar -I lbzip2 -xpf …/…/Tegra_Linux_Sample-Root-Filesystem_R32.5.1_aarch64.tbz2
sync

cd …
sudo ./apply_binaries.sh
sync

Put the device in recovery mode and flash the device with below command.

sudo BOARDID=2888 BOARDSKU=0001 FAB=400 BOARDREV=H.0 ./flash.sh jetson-xavier mmcblk0p1

hello sivashankar,

once you install it via SDKManager, the JetPack release already install to your local host machine, you don’t need to download rootfilesystem and re-create the image.
please check ~/nvidia/nvidia_sdk/ for the release image. you may use the flash script to re-flash the board directly.
thanks

1 Like

Yes. I have not downloaded. copied the above files and started flashing.
Thanks for the information. Will update the status in few minutes

I am facing same issue. Attached complete terminal log as well as screenshots of the message displayed. Let me know if any clarification required.



Xavier_terminallog_20210629.txt (57.0 KB)

several questions as below,

  1. is this host machine using VM or native ubuntu OS,
  2. what’s the power supply of the Jetson AGX Xavier you’re using?
  3. could you please setup serial console with port-J501 to gather bootloader logs, it’s Micro-USB connector provides access to the UART console
  4. is it able to have ubuntu 18.04 to flash the board again to rule out hardware issue?
  1. It is native OS only.
  2. I used the power supply comes along with the device 19v / 3.42A
  3. Will try to collect and send you the logs
  4. In the same host i flashed the another AGX Xavier successfully. I will check the the OS 18.04 and update you.
  5. Is it possible to make a factory default state in the hardware so that i can try fresh flash.

hello sivashankar,

it’s entering forced-recovery mode and re-flash the image to restore the board.
I’m afraid this Jetson AGX Xavier is broken since you’re having trouble communicate with the target during image flash.

please do several approaches to narrow down the issue,
for example, 1. using ubuntu 18.04 to flash the board. 2. flashed with last known good JetPack release image.

if you believe that your Jetson product is defective, please contact the NVIDIA Customer Care team for the RMA process.
thanks

1 Like

I tried on Ubuntu 18.04 64-bit using SDK manager, still it hang at 99%. Attached the log.
When i try to take the UART(ttyUSB3) prints, nothing printed. Any reason.
SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_AGX_Xavier_2021-06-30_12-36-12.zip (811.9 KB)

suggest you contact the NVIDIA Customer Care team for the RMA process.

What is the possible causes this issue? please let me know. Also i bought this on Jun 2019. what is warranty period?

hello sivashankar,

it should be hardware issue since you’ve already narrow down the environment issue, and you also had another AGX Xavier which could flashed normally.
please also check Jetson FAQ | NVIDIA Developer for the detail information.
thanks

Ok. Thanks for the support @JerryChang

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.