Jetson xavier agx error

I have cloned Xavier AGX into sd card by following the and i already successfully got system.img

Everything is done well, until when i try to flash it i getting error.
When the my device is in recovery mode, i use lsusb command on HOST and there is list line of Nvidia Corp show but i still getting the error

Did i do anything wrong while trying to
command : sudo ./ -r - system.img mmcblk1p1
Error : probing the target board failed. Make sure the target board is connected through USB port and is in recovery mode

Hi @Ryujin6

If your lsusb looks like this:

ID 0955:7019 NVidia Corp.

Can you try this command:
sudo ./ -r -k APP jetson-xavier mmcblk0p1

Hi, @mehmetdeniz
Yes my lsusb looking like this

ID 0955:7019 NVidia Corp.

I already tried this command but still getting the same error

sudo ./ -r -k APP jetson-xavier mmcblk0p1

after a few time try i found out that during boot it show error

error : failed to start configure USB flashing port

do this the one causes the problem ?

I think we better not discuss about clone topic at this moment.

What I want to know is did you ever flash your board with

hi @WayneWWW

i actually get this jetson xavier agx from someone so i not sure if that person flash before, but for me i did not flash it before due to this error

Then we should do it step by step. You should get familiar with how to flash the board first.

Your comment reveals that you didn’t know how to flash the board. Please refer to the quick start guide first.

okay my current problem is I’m getting error when i run

Error : probing the target board failed. Make sure the target board is connected through USB port and is in recovery mode

but when i check my jetson is already in recovery mod and when i lsbus using host it show list that have nvidia corp which is correct

Bus 001 Device 024: ID 0955:7019 NVIDIA Corp

but when it will show error above

nvidia corp in lsusb is no longer a 100% precise way to make sure your board is in RCM after rel-32.

Even in normal status, our usb port will serve as device mode so you can see nvidia corp from host too…

Please connect micro usb port on your xavier devkit to your host and open /dev/ttyUSB3 on your host. This will show the uart console, if your board is in recovery mode, then the uart console should suddenly give no response to your command.

i have done the command give /dev/ttyUSB3 and i did not get any responses while I’m in recovery mode

Ok, then we check the host side. Is this ubuntu host a VM?

I’m using VM ubuntu

Please find a native ubuntu 16.04 or 18.04 x64 host. or sdkmanager is not supported on VM.

alright thank you