USB Ports Jetson AGX Xavier don't work after the updating of Linux packages

Hello everyone,

This was the first time I turned on my Jetson AGX Xavier, entered the password, and updated the Linux packages in Software updater. After that, I rebooted the Jetson. When I tried to enter the password after the reboot, not one USB port worked. Right now I can’t go past the password input screen, because the mouse and keyboard don’t work.

Could you tell me how to solve this problem so that the USB ports work?

Are you using the NVIDIA jetson developer kit? or some custom board from other vendor?

I am using the custom board from Robosense.

Please flash back to the original driver package from Robosense.

Remove nvidia related source from the apt source list.

The vendor seems not tell you that “apt get upgrade” will install the defaul jetpack package from us. Such package will install driver/configuration that could only work on developer kit but not custom board. Thus, need to remove nvidia related package from source list.

Thank you for the help, I didn’t know this. Unfortunately, I am not a professional and I have an additional question. How to flash back to the original driver? I mean, I don’t know how to go past a password screen, if my keyboard and the mouse don’t work.

How did you flash your board last time? Did you ever do this before?

I mean your comment sounds like you didn’t ever use this before.

Yes, I didn’t use this before. I received the Jetson, updated the packages, USB stopped working. This was the whole of my Jetson using.
I tried to use JetPack, but the host computer doesn’t see the Jetson (I used the connection by USB-USB C wire).

Wait a second here.

So your vendor didn’t tell you what software should be installed for their board. Do they claim that this board supports sdkmanager?

Thanks a lot for the help, the tech support from Robosense helped me to solve my problem.

1 Like

Could you share what is the solution provided by them here so that other users who also use their board can see this?

You were right. It was my fault, that I didn’t see the note in the guide of the board. There was a notation about drivers for the periphery. The custom board has specific periphery drivers. When I installed the drivers from Nvidia, the periphery stopped working.
The solution is to contact the vendor and ask for the image with needed drivers and guide on how to reinstall the system on the board. Thank you for the support.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.