USB Ports not working new Jetson Xavier NX Dev kit


I just received my Jetson Xavier NX dev kit. However after booting from the SD card it seems like the USB ports are not working.

It boots to the configuration setup on the Ubuntu desktop, but at that can’t proceed with the setup since my keyboard and mouse are not functioning.

I connected a rs232 to Serial adapter to the Xavier NX and logged the boot sequence. I would appreciate help getting this working.

sd card image used: nv-jetson-nx-sd-card-image-r32.4.2

jetson-xavier-nx-teraterm.log (541.0 KB)

Odd. It does look like the WiFi/BT card is being recognized which is also USB.
A few things I’d try…

  • Boot without anything connected to the USB ports, then when the desktop starts, plug in the keyboard and mouse and watch the messages on the serial console.
  • If you have access to another Linux machine, mount partition 1 on the sd card and change /boot/extlinux/extlinux.conf to add text to the end of the first APPEND line. This will turn on more kernel messages.
  • Reflash the SD card (it’s a long shot but you never know)

I’ll try these things. Hope I’m wrong but it’s likely received a bad board from Nvidia. Since the normal procedure should be flash plug in and enjoy ML goodness.

I am in the middle of building a Robot and wanted to upgrade my Jetson Nano with the Xavier NX. Sigh… hope there is a way to fix this.

Thank you for your help gtj. I’ll reply with the results.

You can do headless w/o keyboard, mouse, and monitor. Just connect a microUSB-to-USB cable to your Windows laptop or Linux host and launch a putty session (on Windows) or minicom (on Linux) to the proper COM port.

gtj: I tried everything you recommended with no luck USB-A ports are not working. No changes when plug-in in after I get to the configuration screen and re-flashing several times did not help.

Colin: I was able to connect via serial connection as you suggested. This surprised me since it’s usb3 but makes sense if it’s going through a different ic like a onboard ftdi chip. That would be independent of the other usb3 ports. I am going through the setup now and I’ll update the thread on my progress.

I appreciate both of your suggestions and assistance.

It seems for NX carrier board, this microUSB-to-USB serial port is the only console you can use to do initial setup/configuration. I tried onboard UART serial ports via those jumper pins and TTL serial cable but I’m not allowed to do setup with it except for viewing console logs. And BTW, once you finish setup, this same microUSB-to-USB connection also gives you network link so you can talk to NX module with IP address

I was able to login via ssh using the micro usb-to-usb connection.
assigned it

Still no success with keyboard and mouse usb3 seems to be dead on my jetson:

Here are some logs hope some one can look at these and let me know whats happening. I am looking them over now my self if I find a smoking gun I’ll post what I find.

@jetson-X-nx:~$ lsusb -v -t
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=tegra-xusb/4p, 10000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=tegra-xusb/4p, 480M
|__ Port 2: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 3: Dev 3, If 0, Class=Wireless, Driver=rtk_btusb, 12M
|__ Port 3: Dev 3, If 1, Class=Wireless, Driver=rtk_btusb, 12M

sudo cat /sys/kernel/debug/usb/devices
sys-kernel-debug-usb-devices.log (2.9 KB)

I have included a complete dmesg log dump:
dmesg-dump.log (83.0 KB)

Can you tell if the devices are getting power? Maybe that’s the issue. Do have something like a USB<>SATA dock that takes external power to see if it’s recognized?

I don’t have problem to connect USB keyboard, mouse, or SATA disk drive. The disk driver is using external power though. Here is the dmesg log:

===Insert keyboard===
[149597.505532] usb 1-2.3: new low-speed USB device number 4 using tegra-xusb
[149597.538003] usb 1-2.3: New USB device found, idVendor=04d9, idProduct=1203
[149597.538025] usb 1-2.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[149597.555124] input: HID 04d9:1203 as /devices/3610000.xhci/usb1/1-2/1-2.3/1-2.3:1.0/0003:04D9:1203.0001/input/input5
[149597.616234] hid-generic 0003:04D9:1203.0001: input,hidraw0: USB HID v1.11 Keyboard [HID 04d9:1203] on usb-3610000.xhci-2.3/input0
[149597.631772] input: HID 04d9:1203 as /devices/3610000.xhci/usb1/1-2/1-2.3/1-2.3:1.1/0003:04D9:1203.0002/input/input6
[149597.690438] hid-generic 0003:04D9:1203.0002: input,hidraw1: USB HID v1.11 Device [HID 04d9:1203] on usb-3610000.xhci-2.3/input1

===Insert Mouse===
[149645.873331] usb 1-2.2: new low-speed USB device number 5 using tegra-xusb
[149645.898042] usb 1-2.2: New USB device found, idVendor=04f2, idProduct=0939
[149645.898064] usb 1-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[149645.898071] usb 1-2.2: Product: USB Optical Mouse
[149645.898076] usb 1-2.2: Manufacturer: PixArt
[149645.908614] input: PixArt USB Optical Mouse as /devices/3610000.xhci/usb1/1-2/1-2.2/1-2.2:1.0/0003:04F2:0939.0003/input/input7
[149645.909125] hid-generic 0003:04F2:0939.0003: input,hidraw2: USB HID v1.11 Mouse [PixArt USB Optical Mouse] on usb-3610000.xhci-2.2/input0

===Insert SATA drive===
[149826.713006] usb 2-3.1: new SuperSpeed USB device number 3 using tegra-xusb
[149826.733779] usb 2-3.1: New USB device found, idVendor=174c, idProduct=55aa
[149826.733790] usb 2-3.1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[149826.733796] usb 2-3.1: Product: ASM1153E
[149826.733802] usb 2-3.1: Manufacturer: asmedia
[149826.733808] usb 2-3.1: SerialNumber: 123456789012
[149826.742689] scsi host0: uas
[149826.775518] scsi 0:0:0:0: Direct-Access ST4000DM 004-2CV104 0 PQ: 0 ANSI: 6

thanks Colin

None of that happens when I attach or remove usb devices. No devices show up in the dmesg log and lsusb does not show any newly connected HID devices.

I have emailed Nvidia yesterday and gotten no reply so far. Can’t get phone support due to Covid-19. I think I should get a replacement since it seems like everything else works except usb3 also I got this board yesterday I expect it to just work.

Can someone from Nvidia comment?

Tried that yesterday and nothing gets power from the usb3 ports. As a long shot I tried connecting the keyboard to a external powered hub plugged into one of the Xavier’s usb3 ports unfortunately that did not help.

Looking at your usb devices log, I don’t see the Realtek hub on the carrier being recognized so either it’s not getting power or it’s just bad.

I suppose there could be an issue with the SOM or maybe something in the contacts. Try removing the SOM from the carrier and make sure the contacts are all clean and there’s no obvious damage. You are using the power supply that came with the NX devkit right? It’s a 19v supply as opposed to the 5v needed by the Nano.

If you have a B01 revision of the Nano devkit, you can try putting the NX module on the Nano carrier and make sure the module is working with the Nano devkit USB.

I have inspected all the contacts. Blew out the contacts on the receiver board with a air duster. The usb3 ports still don’t work.
I am and have been using the supplied power supply which provides 19v.

I took out SOM out and installed it in my B01 jetson nano devkit and everything worked. So the problem is with the devkit’s carrier board. Looks like the one Nvidia sent me is bad.

Well, at least you know for certain now. :(

@gtj Yeah. Requested a RMA. Hope this is an efficient process.
Thanks for the help both you and @Colin. It’s a good forum. I’ll try to contribute in the future.