Jetson Generative AI Playground Site Launched

Home - NVIDIA Jetson Generative AI Lab

“Jetson Generative AI Playground” Site Launched

We are thrilled to announce that we launched “Jetson Generative AI Playground”, a tutorial documentation site for demonstrating how to run popular open-source LLMs and txt2img models using open-source tools on your Jetson!

Jetson is a great platform to run large generative AI models and lets you explore the exciting possibility of generative AI at the edge.

What the tutorials cover

By following the tutorials on the site, you can quickly set up your Jetson with a pre-built container to run popular open-source web UI tools for LLMs (text-generation-webui) and for image diffusion models (stable-diffusion-webui).

The site also has pointers to advanced-level tutorials to show techniques to utilize large foundation models on Jetson through knowledge distillation.

Share your project

When you come up with your Jetson-based project that utilizes an LLM, a txt2img model, or any generative AI models, be sure to share on our Jetson Projects board of our Jetson Forum here.

1 Like

I tried going through the initial pre-setup:

sudo systemctl disable nvzramconfig.service
sudo systemctl disable nvargus-daemon.service
sudo systemctl set-default multi-user
sudo reboot

After reboot, I do not have any display on my Jetson Orin Nano 8GB. What should I do? (I just connected to my Jetson using SSH but I have NO display at all) How can I run the rest of the tutorial on my device without a display?

If you have the SHH connection to the Jetson from other machines, you can keep working on the SSH terminal.

Eventually, you will need to access the web UI server from a web browser, but you don’t want to use Chromium browser on Jetson on its desktop because that would also consume RAM.

So my recommendation is to keep working on SSH, and also access the web UI server (running on Jetson) remotely from a web browser running on your other machine (via network).

If you didn’t have SSH access and need to regain the terminal access, you can try pressing Ctrl+Alt+F1, Ctrl+Alt+F2, etc to bring up a terminal login on the attached monitor.

1 Like