Jetson Nano No Response

Im new on jetson,when i want to restart the jetson before install system,i just truned off the power and when i tried to turn on it,no screen response and also no keyboard response.
Green LED and my jetson case’s power LED is on,the screen has no signal.
Also i used the RESET button(i think on GPIO is RST) and still no any response.
pls i need help

You would have to provide a serial console boot log to see what is going on. Alternatively, if it is just the display not working, you could log in via ssh and get the dmesg log. Serial console is always the recommended debug tool for logs. See:

Perhaps it is just display? On the other hand you should never stop a computer by just pulling the power or hitting the reset button. The ext4 filesystem has a journal to prevent corruption (unless the data involved exceeds the journal size), but a replay of a journal essentially removes content which had been cached and not flushed to disk. You will lose content with journal replay even if the filesystem is technically not damaged (content on a filesystem is separate from whether the filesystem itself is not corrupt).

i dont know how to serial console boot log and there,and idk how to connect to ssh(i have ssh tool but idk the passwd and username)
and the screen has power but no signal.
ty very much

The URL link I gave above is information on how to use serial console for logs.

Do you have another Linux computer on the same network as the Jetson? If so, then ssh is simple. By default the micro-USB cable would provide an IP address of for the Jetson when connected in most cases. If the wired ethernet is connected to the same router as the host PC, then this too would assign an address (but you’d have to figure out from the router what that address is). If the user name you log in with is “user” (just an example, adjust for your case), and if the address is visible from the host PC, then ssh login would go like this:
ssh user@

The above would lead to a text command prompt. First login would probably ask if you believe the connection is legitimate. You would have a command line prompt and simply run the command “dmesg”. Copy and paste that and post here (highlight this with your mouse in the forum and mark it as “code” via the icon “</>”).

no i cant cuz i input the lan and the lan’s green led is not working(either the orange one)
also i cant find the address from the router.

@linuxdev already shared how to dump serial console log in previous comment. I don’t know why you still don’t know how to dump.

Please be aware that if you keep saying that “I don’t know” or “I cannot” without really sharing useful info, then no one is able to help you.
If you don’t know something, then please share us which part in the tutorial that you cannot understand.

yes ik this,but i dont have the Adafruit USB to TTL Serial Cable
can i do this with anothor way?

No, this could be only done with the help of those devices.

A serial cable is relatively inexpensive, and very very useful for anyone developing on any embedded system. I highly recommend having this, but there is perhaps one other way if and only if the system is actually booting and the only issue is the GUI: Use CTRL-ALT-F3 and see if you can reach a command-line-only prompt. You’d have to give the Jetson plenty of time to boot as the prompt would be one of the last things made available during a boot. This prompt is not the best access, but it does allow logs to be examined, and (should it work) the output of dmesg would help.

i got the cabel now,but i dont have a ubuntu pc,i installed YAT(it supports serial cmd),how can i connect to my jetson rn?

Just prepare a ubuntu PC first. You may still need a ubuntu host even after we check the log. I mean the process of recovery may require a x86_64 ubuntu PC.

i’ve installed the ubuntu on my pc,and i installed the minicom,but i cant use
sudo minicom
how to fix this?

You can also use other tools like picocom.

Is the UART cable USB end connected to the host PC? See this for information on serial console setup:

On the host PC, if you monitor “dmesg --follow”, and then connect the USB end of the serial UART cable, what do you see? Depending on the brand of chipset in the cable it might assign a name such as “/dev/ttyUSB0” or “/dev/ttyACM0”. Assuming it uses ttyUSB0, then you could use something like gtkterm (my personal favorite) like this (steps include install):

sudo apt-get install gtkterm
sudo gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyUSB0

Also note that when bare wires are used that the serial UART cable can be purchased with different voltage level specs. The Jetson uses 3.3V. Verify your UART cable uses the 3.3V spec.

here is the log,what happend?

Please use sdkmanager to flash the board. The bootloader is corrupted.

ok i’ll try it

uhhh may i ask how to connect to my jetson by sdkmanager?
which line should i use?

Incidentally, if you go into the menu of gtkterm (or most any serial console program) it can log the entire session to you host PC (which can be attached to the forum more easily than adding to pastebin).

Basically it looks like it can’t find QSPI partitions (this is memory on the Jetson itself, and is the location of the corrupt bootloader). Normally one would flash the QSPI with the release version matched to the SD card which will be used, but QSPI often does not change, so sometimes you can change SD card without flashing QSPI.

You can get JetPack/SDK Manager here (look for the release which matches what your SD card was intended for):

This uses the micro-USB connector during flash.

so you mean i just need to reinstall the system of sd card?
and are there any useful tools for sd card formatting?