Jetson nano performance as mentioned in the document

Please provide complete information as applicable to your setup.

• Jetson nano)
• DeepStream Version v5
**• 4.4DP - Jetpack
**• 7.1,0,16

I am trying to run deepstream-app on jetson nano , but I am using 100% GPU with single source and adding another source gives me segmentation fault. Am I missing something ?

Following is the link which mentions extraordinary performance by jetson nano
https://docs.nvidia.com/metropolis/deepstream/dev-guide/index.html#page/DeepStream_Development_Guide/deepstream_performance.html#wwpID0E1HA

My config :
# Copyright © 2018-2020 NVIDIA Corporation. All rights reserved.
#
# NVIDIA Corporation and its licensors retain all intellectual property
# and proprietary rights in and to this software, related documentation
# and any modifications thereto. Any use, reproduction, disclosure or
# distribution of this software and related documentation without an express
# license agreement from NVIDIA Corporation is strictly prohibited.

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl
#kitti-track-output-dir=../../../kitti_track/

[source0]
enable=1
type=4
latency=500
uri=rtsp://admin:@192.168.1.12:554/mode=real&idc=1&ids=1
num-sources=1
#drop-frame-interval=2

[source1]
enable=0
type=4
latency=500
uri=rtsp://admin:@192.168.1.12:554/mode=real&idc=1&ids=1
num-sources=1
gpu-id=0

[source2]
enable=0
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=4
latency=500
uri=rtsp://admin:@192.168.1.11:554/mode=real&idc=1&ids=1
num-sources=1
#drop-frame-interval=2
camera-id=2
gpu-id=0
# (0): memtype_device   - Memory type Device
# (1): memtype_pinned   - Memory type Host Pinned
# (2): memtype_unified  - Memory type Unified
cudadec-memtype=0

[source3]
enable=0
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=4
latency=500
uri=rtsp://admin:@192.168.1.100:554/mode=real&idc=1&ids=1
num-sources=1
#drop-frame-interval=2
camera-id=100
gpu-id=0
# (0): memtype_device   - Memory type Device
# (1): memtype_pinned   - Memory type Host Pinned
# (2): memtype_unified  - Memory type Unified
cudadec-memtype=0

[source4]
enable=0
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=4
latency=500
uri=rtsp://admin:@192.168.1.101:554/mode=real&idc=1&ids=1
num-sources=1
#drop-frame-interval=2
gpu-id=0
camera-id=101
# (0): memtype_device   - Memory type Device
# (1): memtype_pinned   - Memory type Host Pinned
# (2): memtype_unified  - Memory type Unified
cudadec-memtype=0

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=1
qos=0
sync=0
source-id=0
gpu-id=0
nvbuf-memory-type=0

[sink1]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File
type=1
sync=0
qos=0
source-id=1
gpu-id=0
nvbuf-memory-type=0

[streammux]
gpu-id=0
##Boolean property to inform muxer that sources are live
live-source=1
batch-size=2
##time out in usec, to wait after the first buffer is available
##to push the batch even if the complete batch is not formed
batched-push-timeout=40000
## Set muxer output width and height
width=1920
height=1080
##Enable to maintain aspect ratio wrt source, and allow black borders, works
##along with width, height properties
enable-padding=0
nvbuf-memory-type=0
## If set to TRUE, system timestamp will be attached as ntp timestamp
## If set to FALSE, ntp timestamp from rtspsrc, if available, will be attached
# attach-sys-ts-as-ntp=1

# config-file property is mandatory for any gie section.
# Other properties are optional and if set will override the properties set in
# the infer config file.
[primary-gie]
enable=1
gpu-id=0
model-engine-file=../../models/tlt_pretrained_models/peoplenet/resnet34_peoplenet_pruned.etlt_b1_gpu0_fp16.engine
batch-size=2
#Required by the app for OSD, not a plugin property
interval=0
gie-unique-id=1
nvbuf-memory-type=0
config-file=../tlt_pretrained_models/config_infer_primary_peoplenet.txt

[tracker]
enable=0
# For the case of NvDCF tracker, tracker-width and tracker-height must be a multiple of 32, respectively
tracker-width=640
tracker-height=384
#ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_iou.so
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_nvdcf.so
#ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so
#ll-config-file required for DCF/IOU only
#ll-config-file=tracker_config.yml
#ll-config-file=iou_config.txt
gpu-id=0
#enable-batch-process applicable to DCF only
enable-batch-process=1


[ds-example]
enable=1
processing-width=1920
processing-height=1080
full-frame=0
unique-id=15
gpu-id=0

[tests]
file-loop=0

Performance improved when I used config_infer_primary_nano.txt , any specific reason?
Also I get segmentation fault when I add more than 1 RTSP streams

ther performance mentioned in the documentation, is for local file.
performance for rtsp stream should be lower, since network latency introduced. and the model you used should have some affection on the performance. you may use trtexec to get infer performance, /usr/src/tensorrt/bin/trtexec

Did you use source8_1080p_dec_infer-resnet_tracker_tiled_display_fp16_nano.txt?
it’s optimized for NANO, infer interval set to 4, to skip batches for infer, to improve performance. tracker used klt which will use CPU, to ease GPU loading. and qos in sink set to 0, with qos set to 1, decode starts dropping frames.

and for segmentation, it should not happen, please check where it segmented.