Jetson TK1 Ethernet Cuts Out

All, I am having trouble with my ethernet cutting out on my Jetson board. I’ll be sshed in and then all of a sudden nothing. I’ve set a static ip and that hasn’t helped. I’ve been looking at the syslog and dmesg.log and I can’t find anything that strikes me as odd.

  • Has anyone else experienced this?
  • What information can I provide to diagnose this?

I can’t say I have had it cut out and I own 9 Jetson TK1s which are connected and online 24/7.

Check your cables, switch and maybe try pinging your gateway for a while and see if it drops off.

Definitely on the Jetson side. It’s the network at work and only the jetson drops out.

Also I haven’t looked into this, but I can’t seem to ping into, or out of the jetson. Something about icmp socket (but again I haven’t looked into it at all.) I’m sure it’s a just a configuration setting on the L4T distribution.

I’ve seen the same ping errors, although the network works just fine.

I wonder which client/host you are ssh connecting from? I know when I ssh in from linux it never has any delays…but if I use PuTTY from windows 7, the authentication is somehow being done with a different order in which it hangs for a moment. My thought is perhaps it is dealing with ssh at those moments and the ssh client first tries some form of authentication which times out…and periodically does this. Which ssh client and host platform are you using?

I am using OpenSSH on ubuntu 12.04 64 bit. It’s been pretty stable today… I removed the wireless keyboard and mouse from the usb3 port, I wonder if that had anything to do with it.

I’ve had plenty of moments when wireless mouse failed momentarily (never used a wireless keyboard). I only use a wireless with a laptop these days because of that.

With the network-manager UI, I’ve experienced the gigabit ethernet cutting out. However upon writing my own /etc/network/interfaces it’s been fine.

If your USB devices cut out on the Jetson, try this: https://devtalk.nvidia.com/default/topic/746596/embedded-systems/usb3-port-not-providing-continuous-power-/post/4239587/#4239587

I’ve also not experienced network cutting out…and I directly edited settings in /etc/network/interfaces. All settings are explicitly set for me, with no defaults.

Thanks, I’ll do a manual interfaces file. However, just for discussion, I thought that the interfaces file is ignored when networkmanager is running?

This is probably correct, I haven’t studied it enough to say. What I can say is that even if NetworkManager runs, it might not cover a specific device. I personally set up my network with vi and /etc/network/ file edits, and have both the internal NIC and a mini-PCIe NIC…works great to edit files.

So unless something was done to cause NetworkManager to cover specific interfaces, it seems the default is not use NetworkManager. My static IP addresses do not use DHCP, so this might be related.

It does sound like one of those 2 problems, not the Ethernet port:

  1. NetworkManager crashing (this is common, since many people in the Linux world know that the NetworkManager GUI applet is full of bugs, and thus the solution would be to manually edit your "/etc/network/interfaces" file or using a different network manager instead of NetworkManager).
  2. a USB suspend issue (this is also common, but can be fixed easily by following the link that dustin_franklin mentioned.

I am trying to get the ETHERNET connection between Laptop (Ubuntu 14.04) and Jetson. I have established an ethernet connection on PC with IPV4 setting “shared between computers”. This worked for me but not anymore.

Now the wifi symbol on jetson is flickering. It shows wired connection but does not connect.

Then , On Jetson I edited the wired connection to “Shared between computers” and it shows connection established.

It gets an IP address of 10.42.0.1 and when I am trying to SSH from my PC, it says permission denied when I am trying to input the password.

Then, I tried using with directly connecting Jetson to the network. I can now SSH into it using PC. But I want to connect PC with jetson over ethernet

The original problem the thread was talking about was an actual momentary ethernet failure under some high load circumstances. I’m not certain, but I think the issue lived in L4T versions R21.1 and R21.2. If you are using one of those, gigabit loads might drop a connection. However, it seems like you are talking about something else.

The 10.x.x.x addresses are not Internet routable, so I am assuming anything communicating with the Jetson has to either be directly connected via a switch or via a router which assigned the address. Insufficient information is given to say exactly what though.

Would you be able to provide the output of “ifconfig” on each of the machines (you could limit to the network interface related to the issue if you have more than one)? You could “disguise” any internet routable address if you want, e.g., via “.x” notation like “10.x.x.x”. Also, does ping work from each machine to Jetson, and from Jetson to the other machine?

The Jetson was connected to the PC via Ethernet. That assigned it the address 10.42.0.1. This address is assigned when I have the IPV4 setting on both Jetson and PC as “shared between computers”. Ping output said Network unreachable.

Finally, I switched-off the wireless on my laptop and then the PC was assigned the address 10.42.0.10 and this created a local network between PC and Jetson. This is what I require but it’s just a temporary solution as I still cannot connect Internet on Jetson. This address is assigned when I have the IPV4 setting on both Jetson and PC as “shared between computers”.

When I have the IPV4 setting on Jetson as “Automatic DHCP”, ifconfig shows no IP address assigned to the Jetson and the ethernet cable is unable to establish a connection between PC and Jetson. It does show a wired connection but it keeps trying to connect again and again with failure.

This sounds like you are running into the complications of more advanced network administration, rather than an issue of Jetson itself. In part I say this because of the “Network unreachable”. This could actually be the host assigning an address successfully to Jetson but not having that address’s subnet in its own network.

I think maybe some notes on possible setup would indirectly help. The simplest would be if Jetson has network files edited to use a fixed address, and not DHCP assigned, perhaps 10.42.0.10 to be consistent. Your host would be very unlikely to reach this address without extended setup. Reason 1, if the host itself is DHCP assigned or if the host has a publicly routable internet address, the 10.x.x.x subnet would not be part of the host itself. One could “dual home” the ethernet on a linux host and suddenly this would work. Should you use the linux host to do DHCP assignment, this still remains true…the host’s own ethernet adapters would not have a 10.x.x.x subnet without dual homing or manually adding a second NIC and assigning that subnet. Yet DHCP would be working as expected.

The second point of interest on that example is that even if host has a subnet set up and is able to talk to Jetson, Jetson would be unable to talk to anyone else…your host would need to be set up to forward/route Jetson before Jetson could see the host’s own idea of the internet.

If you have a router, and the router DHCP assigns to Jetson, basic configurations would suggest Jetson and any machine assigned via the router would be able to talk. If for some reason they use different subnets, this would fail without extra forwarding configuration. And of course router security may possibly require devices connected have an administrator account mark the MAC address or other info as allowed.

In my case, I have a second NIC on my host with a static non-internet-routable subnet. Jetson is on the ethernet switch for this, and I’ve set Jetson up by simple file edits to use a static IP address. I then tell my linux host that the Jetson’s address should be port forwarded, so Jetson could reach the outside world. This is still not complete until copying DNS server info from host to Jetson, which completes the story by allowing named addresses rather than only knowing dotted decimal formats.

So the limited information you’ve given regarding routers and which machines have single or dual NICs or dual-homed NICs makes it impossible to give any definite answers. More information needs to be given on how each relevant machine is assiged address, what device is expected to reply to provide the assignment, and whether you are trying to get any other device or host to do forwarding. The earlier ifconfig questions would provide part of that information. And since I edit network files rather than using the GUI interfaces, knowing the result of “shared between computers” remains a bit vague.

Could you give a layout of routers, switches, hosts, and where DHCP is used plus where DHCP is assigned from?