Jetson Tx1 Ethernet problem

Hello, my problem is Jetson Tx1 (J3.1 with 28.1) ethernet not working properly. Ethernet shows connected all the time, but when I want to use internet (for example ping or update or browser) internet goes off. I mean lets say it pings for 3 or 4 times then goes off. For the browser, it shows one site then connection lost. Meantime no ethernet connection lost. And internet comes for 10 seconds then goes off again.
I have tried to give static IP and DNS. No change, then I have flashed OS and switch to J3.2 but problem continues. I have changed the ethernet cable and connection point (all static IP btw). Lastly, Wi-Fi works.
I hate say this but, I haven’t changed anything. One day it malfunctioned. Any help ?
Thanks in advance.

Is the ethernet in question going to a regular router appliance? Or is it going to a Linux PC acting as a router? If this is the former case of a router appliance, then you might want to reboot the router itself…routers are notorious for not dealing well with some cached data needing to be flushed. Reboot flushes the caches.

First of all, I want to thank you and mods, because I have learnt a lot from your comments on the forum.

From your comment, I have create setup. I ve connected my ubuntu PC to internet via wi-fi, then connected to the jetson over ethernet cable. Right now no connection lost after 200 ping seq (still continue).

After that I ve reconnected my jetson to same ethernet port (giving error) , ping stopped at 20 seq. I am connecting to the internet from the university. I believe there is a router with ups. Btw I have tried other ethernet ports at my lab still connection lost. But I think so that it is caused by router or switch.

What should I do? Any advise. I think, I should write to the IT. Can I do something extra?
Thanks in advance.

So am I correct that this is wired ethernet the Jetson to the PC, followed by WiFi to a university network? Is there a single switch which both the PC and Jetson are connected to and otherwise there is nothing on the wired switch? Is there any WiFi being used on the Jetson?

Do you see any error from “sha1sum -c /etc/nv_tegra_release” (no need to copy output unless a file is found not ok)?

Are there any other work loads going on at the time?

Before you do something where the network fails, and then again after a failure, what does this command say (error information may change between the before and after):

ifconfig eth0

See what this shows before any error, then again after…if it turns out there is a difference it would be useful to see both the before and after…if no diff, then the unchanged output would still be useful:

dmesg | egrep -i '(r8152|ether|eth0)'

When you ping and it fails perhaps it would be useful to ping from both the PC and the Jetson at the same time to the same address…see if this is an issue for the PC as well. Start both pinging at the same time.

When you ping do you use a dotted-decimal format address, or do you use a named address? Example, “” has an address “”…I know this because of the command “host” (some addresses listed are irrelevant, I’m interested in the old style numeric address). I would suggest simplifying first by trying ping to only the dotted-decimal format…when you use a named address DNS must perform the conversion and it complicates the chain (in theory there would be only one query at the start and then the same address in dotted-decimal form would be used internally for each ping after that…but you wouldn’t know if host and Jetson use the same address). The address should be to something with a big/fast pipe ( is good for that).

What is the address of your PC so far as your wired connection goes? You can use “ifconfig” from the PC to see, but naming might differ for the network device depending on software. Having a ping from Jetson to PC at the same time could also rule out local Jetson-to-host issues.

linuxdev thank you for your asistance, I dont know what happended, but today I have started jetson (last setup was static IP to PC) with ethernet cable attached to the university net at the same port that gives error. Then there is no internet, then I have tested “ifconfig eth0” as you mention and saw that IP is static (which I use for connecting to computer), I changed it to automatic (btw I have tested this many times). Now it works, I can ping to google with decimal and direct address. 600 ping seq and no error. Browser working as well.

Now I will install OS on SSD since I have formated it. Then I will check it again. I haven’t writed to IT but maybe they have restarted router.

Lastly, my test setup was jetson connected to the PC via ethernet, PC connected to the internet via wi-fi, wi-fi was mobile hotspot from my mobile phone.

Thank you.

Glad it worked…it can be frustrating to deal with a network you don’t have full control over (or sometimes even a simple private network). One thing to be aware of on a university network is to be sure your passwords are changed…everyone in the world with a port scanner knows the default logins to the Ubuntu admin account.