Unable to Ping, Tx1. Unable to SSH into Tx1

Hi Folks,

I am unable to ping Tx1 (WiFi/internet on Tx1 seems work - as I am able to post this !). Following is the output of my query -

sudo service sshd status
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2017-05-25 21:21:52 UTC; 3min 14s ago
 Main PID: 5768 (sshd)
   CGroup: /system.slice/ssh.service
           └─5768 /usr/sbin/sshd -D

May 25 21:21:52 tegra-ubuntu systemd[1]: Starting OpenBSD Secure Shell server...
May 25 21:21:52 tegra-ubuntu sshd[5768]: Server listening on 0.0.0.0 port 22.
May 25 21:21:52 tegra-ubuntu sshd[5768]: Server listening on :: port 22.
May 25 21:21:52 tegra-ubuntu systemd[1]: Started OpenBSD Secure Shell server.
ubuntu@tegra-ubuntu:~$ sudo service ssh status
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2017-05-25 21:21:52 UTC; 8min ago
 Main PID: 5768 (sshd)
   CGroup: /system.slice/ssh.service
           └─5768 /usr/sbin/sshd -D

May 25 21:21:52 tegra-ubuntu systemd[1]: Starting OpenBSD Secure Shell server...
May 25 21:21:52 tegra-ubuntu sshd[5768]: Server listening on 0.0.0.0 port 22.
May 25 21:21:52 tegra-ubuntu sshd[5768]: Server listening on :: port 22.
May 25 21:21:52 tegra-ubuntu systemd[1]: Started OpenBSD Secure Shell server.
u

Any Idea why is - Server listening on 0.0.0.0 port 22 ? and not it actual ip addr -as reported by ifconfig

Thanks

0.0.0.0 is just a definition of local traffic. Often when interfaces are arranged with something that might change a lot (think WiFi while moving) there is still a need to keep network services running even if you can’t reach outside of the local computer (for example, X11 is network based and would fail if there were no local network abilities when WiFi goes down).

So from an external host, can you see DHCP requests on your router when it boots? Can you ping by dotted-decimal address (ignore named addresses like “tegra-ubuntu”, this requires further setup to look up names)? Is wired ethernet connected (this is far simpler and more reliable than wireless)? If you really want to see what goes on you’ll want to get to a serial console. See:
http://elinux.org/Jetson/TX1_Serial_Console
http://www.jetsonhacks.com/2015/12/01/serial-console-nvidia-jetson-tx1/

Are the systemctl commands from the Jetson? I was thinking you couldn’t get in at all, but maybe you are saying it runs, just not over the network. If you have access to the Jetson, run the command “ifconfig”.

Thanks linuxdev for helping.

Yes I systemctl commands are from jetson. I am able to work on it and run internet. Like posting this message. Following is output of ifconfig command …

ubuntu@tegra-ubuntu:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:4b:65:b8:49
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:429 errors:0 dropped:0 overruns:0 frame:0
TX packets:429 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:37832 (37.8 KB) TX bytes:37832 (37.8 KB)

wlan0 Link encap:Ethernet HWaddr 00:04:4b:65:b8:47
inet addr:10.33.55.12 Bcast:10.33.55.255 Mask:255.255.255.0
inet6 addr: fe80::204:4bff:fe65:b847/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3472 errors:0 dropped:0 overruns:0 frame:0
TX packets:1281 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:981576 (981.5 KB) TX bytes:159308 (159.3 KB)

HI Linuxdev,

The wired ethernet is not connected. I am able to ping other machines on our local network from this machine. I am also able to scp out our result files form jetson to other machines. Problem is that other machines are not able to come in and ssh into jetson.

Thanks

It sounds like the Jetson is fine, but firewalls or WiFi router security is an issue. I am not able to debug WiFi issues, but even WiFi is probably not at fault…the router part of a WiFi router is just a normal router which happens to deal with wireless connections. So can you describe your WiFi router? Is this a standalone appliance you can check logs on and security settings?

On the Jetson side run “dmesg --follow” to monitor and see if notes are added while an outside application attempts to connect. See if ssh to localhost…from Jetson to Jetson…works, and if not, check the same dmesg output. Additionally, monitor “sudo tail -f /var/log/auth.log” while attempting the logins…see if sshd makes notes. If remote logins do not show anything, it means the network was probably blocked by the router or other outside firewall (local ssh to Jetson from Jetson should always make notes in logs, the router won’t be in the way). If local ssh login direct to Jetson from Jetson fails, then you know you have an sshd or local firewall issue.