Port 22: Connection refused connecting via SSH on jetson tx2 developer kit

I get the following error when trying to connect to my jetson tx2 dev kit

matt@xps:~$ ssh nvidia@10.5.48.1
ssh: connect to host 10.5.48.1 port 22: Connection refused

On the jetson:

nvidia@jetson-dev:~$ arp -a | grep -Eo '([0-9]*\.){3}[0-9]*'
10.5.48.1
nvidia@jetson-dev:~$ ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:16:1d:01:39
          inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
eth0      Link encap:Ethernet  HWaddr 00:04:4b:e0:00:0e
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:42
l4tbr0    Link encap:Ethernet  HWaddr 4e:7f:01:e3:e3:f2
          inet addr:192.168.55.1  Bcast:192.168.55.255  Mask:255.255.255.0
          inet6 addr: fe80::bcf3:7dff:fe0a:890e/64 Scope:Link
          inet6 addr: fe80::1/128 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:842 (842.0 B)
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:332 errors:0 dropped:0 overruns:0 frame:0
          TX packets:332 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:24701 (24.7 KB)  TX bytes:24701 (24.7 KB)
usb0      Link encap:Ethernet  HWaddr e6:fa:b6:66:e7:6e
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
usb1      Link encap:Ethernet  HWaddr 4e:7f:01:e3:e3:f2
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
wlan0     Link encap:Ethernet  HWaddr 00:04:4b:e0:00:0c
          inet addr:10.5.55.63  Bcast:10.5.63.255  Mask:255.255.240.0
          inet6 addr: 2001:67c:10ec:5745:8000::5a1/128 Scope:Global
          inet6 addr: fe80::6483:baa4:422a:8ab9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1699 errors:0 dropped:0 overruns:0 frame:0
          TX packets:475 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:929679 (929.6 KB)  TX bytes:44857 (44.8 KB)
nvidia@jetson-dev:~$ sudo service ssh status
● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2020-02-21 17:52:33 CET; 12min ago
  Process: 4324 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
 Main PID: 4329 (sshd)
    Tasks: 1
   Memory: 868.0K
      CPU: 28ms
   CGroup: /system.slice/ssh.service
           └─4329 /usr/sbin/sshd -D
Feb 21 17:52:33 jetson-dev systemd[1]: Starting OpenBSD Secure Shell server...
Feb 21 17:52:33 jetson-dev sshd[4329]: Server listening on 0.0.0.0 port 22.
Feb 21 17:52:33 jetson-dev sshd[4329]: Server listening on :: port 22.
Feb 21 17:52:33 jetson-dev systemd[1]: Started OpenBSD Secure Shell server.
nvidia@jetson-dev:~$ sudo netstat -anp | grep sshd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      4329/sshd
tcp6       0      0 :::22                   :::*                    LISTEN      4329/sshd
unix  3      [ ]         STREAM     CONNECTED     48293    4329/sshd

On the laptop:

matt@xps:~$ ping 10.5.48.1
PING 10.5.48.1 (10.5.48.1) 56(84) bytes of data.
64 bytes from 10.5.48.1: icmp_seq=1 ttl=255 time=3.64 ms
64 bytes from 10.5.48.1: icmp_seq=2 ttl=255 time=3.25 ms
64 bytes from 10.5.48.1: icmp_seq=3 ttl=255 time=5.35 ms

I tried to reinstall openssh-server as some people suggested on behlaf of this issue but no success.
Help is much appreciated.

“ssh” normally works quite well without issues. I did notice that in the “ifconfig” output the address “10.5.48.1” is not listed, and that the wired ethernet has no address at all (the l4t bridge is the virtual wired ethernet over the micro-B USB connector). So whatever it is that responded to a ping to “10.5.48.1” is not this Jetson.

Is the wired ethernet connector of the Jetson connected to a router?

Is the micro-B USB cable connected to another computer?

Hey thanks for pointing out that I was using the completely wrong ip address. I used the “wlan0” address 10.5.55.63 and it worked just fine.I didn’t connect the USB cable, everything over wifi.

Cheers

Is it correct to say it is all working now?