SSH connection issue

Hi guys,
I’m currently using the JetsonTX2 (Jetpack3.3) and I have a weird issue when I want to connect to the Jetson via ssh from a Linux computer.

Here is what I tried to check on the port 22 ssh connection status (xxx.130 is linux computer and xxx.137 is the Jetson) :

vdufour@vdufour-Ampere303R036:~$ sudo nmap -sS -p- 134.214.197.130
Starting Nmap 6.40 ( http://nmap.org ) at 2019-11-14 10:44 CET
Nmap scan report for ampere303-r036.insa-lyon.fr (134.214.197.130)
Host is up (0.0000090s latency).
Not shown: 65534 closed ports
PORT   STATE SERVICE
22/tcp open  ssh

Nmap done: 1 IP address (1 host up) scanned in 5.64 seconds
vdufour@vdufour-Ampere303R036:~$ sudo nmap -sS -p- 134.214.197.137

Starting Nmap 6.40 ( http://nmap.org ) at 2019-11-14 10:45 CET
Nmap scan report for ampere303-r043.insa-lyon.fr (134.214.197.137)
Host is up (0.00057s latency).
Not shown: 65534 closed ports
PORT   STATE SERVICE
22/tcp open  ssh
MAC Address: 00:04:4B:A5:57:A5 (Nvidia)

Nmap done: 1 IP address (1 host up) scanned in 5.69 seconds
vdufour@vdufour-Ampere303R036:~$ sudo ssh nvidia@134.197.214.137 -p 22
ssh: connect to host 134.197.214.137 port 22: Connection timed out
vdufour@vdufour-Ampere303R036:~$ ssh nvidia@134.197.214.137
ssh: connect to host 134.197.214.137 port 22: Connection timed out

The port seems open and the ssh connection up but it timed out or it tells me there is no route to this address.
The weirder part is when I tried to ssh to the linux computer from the Jetson…and it worked !
How is it possible that it works in one way but not the other when the 2 ports are open ?

Thank you for your help

[EDIT]:
it’s mysteriously solved… I just tried the connection with ubuntu instead of nvidia and it worked, so I retry with nvidia and it worked also…still don’t know why but it does.