ssh and pinging Jetson TX2

Hi everyone,

I am facing some problems with the TX2. I have installed Jetpack over a host PC on the Jetson TX2 and I can ping and remotely access the Jetson from the host.

However I need to route data over TCP/IP from a Raspberry Pi 3 and the Jetson TX2. I have set up the raspberry pi with the new raspbian stretch and made it communicate smoothly with the host computer. However I get the following messsage when I try to ping the RPi from the Jetson and vice-versa:

From XXX.XXX.XXX.XXX icmp_seq=1 Destination Host Unreachable
From XXX.XXX.XXX.XXX icmp_seq=2 Destination Host Unreachable
From XXX.XXX.XXX.XXX icmp_seq=3 Destination Host Unreachable

and when I try to SSH.

ssh: connect to host XXX.XXX.XXX.XXX port 22: No route to host

when I use arp -a it shows:

localhost (XXX.XXX.XXX.XXX) at on wlan0

I have tried so many things but for no avail.

Does anyone have an idea how to solve this?

Hi

I have observed more or less the same, I believe this is a firewall issue in Ubuntu which affects WIFi only. Cable seems to work fine.

Can you try sudo ufw disable ?

I have tried to disable the ufw but it says:

sudo: ufw: command not found

Ahh… yes… sorry. You might have to install UFW or gufw (graphical tool for managing firewall settings)

sudo apt-get install gufw

I disabled the firewall but still unable to reach to host.

I tried all the layers (office, home and public) and nothing happened. Any other ideas?

Does this happen both on WIFI and on cable?

Only Wifi

What address are you using…dotted-decimal format, or named? DNS is required for anything with a name…the exception being addresses manually configured in “/etc/hosts” or for which the router has knowledge.

How much is wired and how much is WiFi? WiFi drastically complicates things…having part of the system on wired and part on WiFi makes it even more difficult.

Both maycondouglasd and I are having this problem. We simply can’t ping the Jetson from any other LAN machine when it’s connected via WIFI. It works as expected when connected via cable.

Does it work for you linuxdev? (Disable cable, enable wifi, try to ping your jetson)

I’m not set up for WiFi. In the past my finding was that NetworkManager sees WiFi and disables wired. Even if wired works there could be issues if not using a dotted-decimal format address on the same router. I am just wondering how much of this is DNS related, and how much is route related…it could be either or both, especially if wired and WiFi routers differ.

It’s neither DNS related nor route related. Like I said - it’s on the same LAN. IPv4 addresses. To me it seems to be Firewall related. Outward connections from the Jetson work fine - it’s just incoming requests (ping, udp video etc) that does not get through whe connected via WIFI.

Try traceroute instead of ping. See which route it is trying to use.

Just to be sure…with wifi is there an access point that RPi and Jetson connect to ?
If not, you would have to make one of these be in master mode to provide the access point (hostapd could do that).

If both connect to another wifi access point, it might be route problem as suggested by @linuxdev.

There is 1 LAN with 1 Access point. Not a routing issue.

I am essentially using WiFi, no cable (I just tested the cable to make sure it works). I am able to ping and remote access from and to the computer to both, jetson and rpi3. However when I try to communicate these two guys directly (say from the Jetson to the Rpi and vice-versa) I am faced with a “destination host unreachable” warning.

I am using dotted-decimal IP addresses, initially they were dynamically set by the network now I made the Rpi static.

I am essentially using WiFi, no cable (I just tested the cable to make sure it works). I am able to ping and remote access from and to the computer to both, jetson and rpi3. However when I try to communicate these two guys directly (say from the Jetson to the Rpi and vice-versa) I am faced with a “destination host unreachable” warning.

I am using dotted-decimal IP addresses, initially they were dynamically set by the network now I made the Rpi static.

ssh offers a “verbose” (or even “more verbose”) debug option. If you are using dotted-decimal, and if ping works, and if the dotted-decimal truly is the system you think it is, then verbose ssh will give more information. Try from each host, but with some restrictions to keep some of the output scroll down for cases which shouldn’t be hit:

ssh -2 -4 -vvv -E ssh_log.txt name@<dotted-decimal-address>

I am hoping ssh at least gets to the host and is rejected, versus not finding the host at all…but I suspect it simply won’t find the host.

I also have the same problem. However, if I plug eth into the device and put it on wired LAN, then I’m able to ssh from host to device via wifi. Note the dmesg output I see after plugging in the eth cable.

[  297.606766] eqos 2490000.ether_qos eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[  297.615948] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[  309.723678] Bridge firewalling registered
[  309.821189] ip_tables: (C) 2000-2006 Netfilter Core Team
[  310.072759] IPv6: ADDRCONF(NETDEV_UP): docker0: link is not ready

If docker is involved, then it might be the issue. To know more you’d need to compare the output of “ifconfig” and “iwconfig” and “route” before and after you plug in the cable. Probably also "traceroute " before and after. Then you’d have an idea of how each interface is being used.