Post JetPack Installation - Error flashing the Jetson kit

Hello,

I am new to Jetson and this is the first time I am getting into Nvidia products, I have got Jetson TX2 along with the developer kit. While installing JetPack at the end of installation where few components need to be installed on the development kit post installation, I had error and it said could not flash run the Jetson file again to reinstall.

After that I also noticed, my monitor screen says no input device (monitor is connected to the development kit). I am not able to see anything on the screen. Please note the screen works fine with other devices as when I connected them.

Any help and guidance will be highly appreciated. Thanks.

This is just some general information since not enough details were given to provide any solid answer.

Often the Jetson is up and running even when video fails…video auto configuration might be the issue. If you use an older 15-pin D-sub VGA monitor this is a guaranteed failure and auto configuration cannot succeed (though you could be very lucky).

JetPack itself is just a front end to flashing and extra package installs. The flash step adds some setup to report its IP address to JetPack once flash completes and the Jetson reboots. If you didnt’ also flash (and lots of people use JetPack to download packages without flashing), then the automatic network address setup will fail and you’ll need to manually enter the IP address.

The first thing to check is if your router sees the Jetson asking through DHCP for an address. This might be a router appliance or your Linux PC acting as a router. You might mention your network setup (router appliance versus PC acting as router). If you see an address, then from your host use ping to see if networking is up. An example which assumes the assigned IP address was 192.168.1.3:

ping 192.168.1.3

Or ssh to that address:

# Either name/pass of "ubuntu"/"ubuntu" or "nvidia"/"nvidia":
ssh ubuntu@192.168.1.3

By far the most reliable and unstoppable debug tool would be a serial console (settings 115200 8N1, no hardware flow control). See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Also beware that many people try to use a VM on the host PC, but VMs don’t work (at least not without either luck or some extra USB configuration…and sometimes not even with that).

If you have some more specific logs or details it would help.

Thank you so much for your help…it really helps…but I am stuck…the reason I am not able to give you more information or paste the log here…as today when I am trying to start Jetson development kit…the monitor screen that is connected to the kit says “no input”…the screen is black and saying jetson is not connected.

Please note: the green lights and red lights are up on the development kit and there is nothing wrong with the monitor screen. Monitor screen when connected with my laptop works fine and I am using the same HDMI cable.

My worst assumption is, is it because everything on the Jetson got deleted or something has gone wrong the HRMI port on the kit or post installation did something bad? Please advise.

Your help and time is highly appreciated.

does it log in to the jetson via the ssh connection?

no…it just does not show anything on the screen…the screen is completely blank of the monitor…

no, you do not just look at the screen, you open with Contrl + Alt + T a terminal at the HOST PC, check the ip address of the jetson at router tables and try ssh from the Host PC to the Jetson ip address, that will show if the issue is monitor specific or some other generic issue takes place.
However, if I were you, first thing that I will do towards a generic issue with jetson is reflash with a newer release - 3.2.1

The gist of the explanation here is that video rarely has any reliable way to say if the system is failing via missing video function…video often fails even though the system is otherwise up and running. Other methods to connect are a useful debug tool.

Look at your wired router logs (and consider WiFi after a flash not likely). If the Jetson requests an address, then it is only video which is failing. If you can ping or ssh, then it is only video failing.

On the Jetson itself the GUI mode video setup differs from console mode. Default is to try to go to GUI, and even if this fails, you can sometimes still use the CTRL-ALT-F2 key combination to get to a purely console mode and do text command operations directly on the otherwise failed Jetson.

If you really need to debug, then there is no substitute for serial console. See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

Do not worry so much…it is quite common to have video issues, and although I’ve heard of failed flashes, I’ve never heard of flashing “bricking” a Jetson. It is highly unlikely anything went wrong with the hardware itself (and if it did go bad, then it wasn’t the flash causing it).

  1. ensure Jetson is connected via ethernet to a router
  2. open router web admin interface [pressumably dhcp leases] and locate ip address of the Jetson at the router
  3. open a terminal at Host PC - it will be konsole at Mac or Terminal in Mac or you can type Contrl + Alt +T in ubuntu and that will open as blank terminal
  4. in the terminal type:
    ssh nvidia@ipaddressofthejetson

Just a note on debugging…if you even see a DHCP request on your router from the Jetson as it boots, then you know it is working. You’ll still need one of those above methods to see what is going on, e.g., the ssh @Andrey1984 mentioned.

Error Reflashing the Jetson again. I am not able to post pictures here, otherwise I would have posted here to show what is the issue.

I connected other TX2 with the same development kit and monitor screen and it works but the Jetson tx2 with which I installed latest jetpack is still not working. When I connect this Jetson tx2 with the same development kit and monitor screen it does not show anything on the monitor screen. The monitor screen says “no input”. The screen is completely blank, and I can’t even get into TX2, I do not even know what is going on.

I’d say that same symptoms, same therapy as proposed by @Andrey1984 or @Linuxdev

Seems your monitor is not correctly handled…Is it an HDMI monitor ? If not HDMI, is at least DVI ? A VGA monitor wouldn’t be able to send edid.
Can you try another monitor (preferably HDMI, not a TV, not too old nor recent ;-)) ?

If no, you have to try to log into your Jetson, either by ssh if it is connected into a network and you can get its address, otherwise with serial console as proposed in post #7. Alternately, have you tried Alt-Ctrl-F2 ? It may use a different video mode that might work, you wouldn’t have GUI but a terminal for investigating further.

Then you may be able to read the EDID sent by your monitor (check /sys/kernel/debug/tegradc.0/edid as root) and maybe use X for mode debugging.

Something of use about the forum itself is that there are ways to attach files, but you can only do this while editing an existing post…not on a new post.

If you hover your mouse over the quote mark icon in the upper right of one of your posts, then you will see other icons pop up next to it. The pencil icon edits your post. The paper clip icon instead allows you to attach a file (there are some restrictions on file type, so if it is a log file you might rename it something with “.txt” suffix).

here are the images attached. THANK YOU @linuxdev.
IMG_3586.jpg
IMG_3587.jpg
IMG_3588.jpg

IMG_3586.jpg

IMG_3587.jpg

IMG_3588.jpg

I think the best way to describe my issue is, I do not even see if my Jetson TX2 even boots up. I do not even see it booting up on the screen. Whereas I have another Jetson TX2 connected on the same development kit via same HDMI to the same Monitor screen and it boots up completely fine and I can see everything and work on it.

But the one that is not working does not even show if it is booting up or not after I turn the power button on, on the development kit. I see all the lights red, and green on the development kit.

Seems flashing the APP partition (rootfs) failed.

Are you using a VM as host ? VMs are known to get into troubles for flashing. If you’re using a VM, you would have to try to configure USB from VM…it depends on the VM (vmware, virtualbox…) but searching this forum you may find some links.

If you’re using a real PC Ubuntu host, you may try another cable… If you have a hub between host and Jetson, try a direct connection.
If you have a direct connection, you may also try to insert a hub between host and Jetson…this is a generally bad advice, but I’ve seen a case where it was the solution for flashing from a very old (and tired) host.