JetPack 3.3-3.2.1-3.1 Installation

Hi all,

my first topic after trying all two day :(

I took tx2 and trying to install first Jetpack 3.3,

all packages are downloaded and installed. Even, the ubuntu is working because it appears in installion with 30 gb hard disk with ubuntu root files. it suddenly appears in X-Term. Finally; these appears:

Flashing is completed.
the target t186ref has been flashed succesfully

Reset the board to boot from internal eMMC.

Finished Flashing OS.
Determining the IP address of target…

AND ITS STUCK.

This isn’t my first error. Before, I took the “ip address is used 192.168.xx.x” error.
This is my current error, after trying 3-4 times of setup.

WHAT I HAD AND TRIED:

Ubuntu 16.04
Micro-usb is plugged in

both tried

1- from host(pc) to wlan and from ethernet of host(pc) to jetson - (2nd option)
2- router both connected via ethernet.

I rebooted the system.

Also Checked with hdmi cable, the OS doesn’t work.

any helps please…

One thing to know when you say it’s stuck is if a USB keyboard LEDs work one minute after it has booted. If the keyboard LEDs works, then it is probably a video configuration issue. This may happen with some monitors, or some adapters (for example, VGA monitors are not able to send EDID to host).
You may use serial console to investigate further.

If your system is alive, you may also try to ssh into it (get its IP from your DHCP server logs).

ismet.dagli27,

If you choose to flash device only (in jetpack), after flashing, tx2 should boot up.

Could you check if tx2 is able to get IP by default?

Keyboard LED Doesn’t work. LED near the power-recovery-CR5-ETHERNET is working only. I’m waiting long enough after pushing reboot button but doesn’t determine IP address. I tried with 3 different monitor with HDMI cable(coming from with original box) but no screen will be shown.

My system should be alive but it isn’t, therefore I can’t ssh into it.

I didn’t choose only flash, I tried to install I jetpack packages.

If I understand correctly second part; TX2 can’t get any ip address but in readme file (coming with L4T), connect via ssh with ip address: 192.168.55.1.
But i can’t connect, also it doesn’t determine ip after flashing, just exists in readme file.

You will probably want to see what is going on via serial console. See:
http://www.jetsonhacks.com/2017/03/24/serial-console-nvidia-jetson-tx2/

FYI, if you flash there is a mechanism to report the address to JetPack (but it is only one-time). If you install packages without flash I believe you will always have to manually add the IP address (watch the console). Usually the router is the way to find out that address if you can’t get local login.

FYI, if the monitor isn’t HDMI I would expect this to fail for video setup.

If the power LED near the ethernet lights, it implies PCIe has power, which is good. On the other hand, if you tap the power on switch and the two green LEDs near this don’t light, then there is a problem. I am assuming this is the dev carrier board, so if not, let us know.

Also, some power sources don’t work as expected. If this is not powered by the adapter which comes with the dev carrier kit please let us know.

At this moment, looks like your device does not boot up successfully so that jetpack cannot detect its IP. Please try to get the serial console log by linuxdev’s comment.

I’m also trying to install Jetpack 3.3 on TX2 with 16.04 ubuntu as host.
But after successfully flashing OS the jetson doesn’t reboot properly. The target screen gets red for a while and goes blank even after the xterm shows this-

Flashing is completed.
the target t186ref has been flashed succesfully

and after this it goes on and installs opencv cuda etc. on target but the screen shows “no signal”.

What might be the issue here? can anyone help? I’m beginner in TX2.
hdmi cable and micro-usb works fine.

thanks,

Piyush

That’s quite different…the system is up and running. The problem is that video automatic configuration is failing. Are there any adapters involved in the video, or is it purely HDMI?

Try logging in with ssh to see what the content of “/var/log/Xorg.0.log” is (serial console works too for this purpose).

I’m using HDMI to VGA converter which had no issue earlier when I booted the Jetson for the first time.
I will try using ssh.
thanks!

I saw the contents of the log and saw this error:
NVIDIA(0):Failed to set the display configuration.

I used different monitor and hdmi to vga cable but still same issue.

As previously said, VGA monitors are not suitable for automatic video configuration, because VGA monitors cannot send EDID.
You may try an HDMI or at least DVI monitor (DVI monitors can send EDID, and most HDMI/DVI adapters support this) if you can get one.

I used this command-
sudo cat /sys/kernel/debug/tegradc.0/edid

and there was some data in the file meaning the monitor is sending EDID

update
I guess Jetpack 3.3/3.2.1 has some issue with display.
Flashed with 3.0, now the monitor display works fine.
thanks everyone for the input.

Glad to hear you’ve found a solution.

However, if you want to investigate further, in order to upgrade to most recent version (having bugfixes and new features), you may copy the output of

sudo cat /sys/kernel/debug/tegradc.0/edid

and paste it into http://www.edidreader.com/ for details. You may check if it is valid and the capabilities.

The EDID is read through an I2C link, but VGA connectors don’t have these signals.
If your monitor is really connected with VGA, I’d suppose :

  • either your adapter embeds an I2C-able controller and sends an (VGA-like) default EDID, whatever monitor is connected. You may post it here, an issue-reported EDID might be a test case for future versions.

  • either the driver has a fallback edid. In such case, it would be interesting to know if the default EDID is different among these JetPack versions.

@linuxdev
@WayneWWW
@Honey_Patouceul

Serial console worked. Ubuntu is installed, I also installed CUDA-CUDNN-TENSORRT with JetPack3.3. Thank you all for help guys

Greeting everyone ,

After many attempt on flashing the JetPack 3.3 on Jetson TX2 dev kit ,
The flashing was successful and reboot the TX2 but
the device turned out not to have all the

    JetPack 3.3 components:
    [b]<li>CUDA 9.0</li>
    <li>cuDNN 7.1.5</li>
    <li>TensorRT 4.0</li>
    <li>VisionWorks 1.6</li>
    

    [/b]

only the OS image of Ubuntu 16.04 LTS managed to be flashed on the TX2
and I cannot run the sample code for CUDA : because the directory were not even created after flashing Jetpack to the target TX2

The following step was applied to the target soon I logged to the TX2

sudo apt-get update
sudo apt-get upgrade

I’d factory reset the TX2 before start over the Jetpack installation again from link :
http://developer.nvidia.com/embedded/dlc/tx2-production-image

I did install the Jetpack 3.2.1 - 3.1
Host run on ubuntu 16.0 & 14.0 (changed host after failed with same issue)
Host and target both connected to a router .

Ended up with the same issue.

Here is the log of the installation :
https://drive.google.com/open?id=1WVOo6k-xV3E2_vKJj7MErcUp0gsCLaVh

Please help me with this issue .

same problem here gal

The log I saw was truncated (it only showed the first part of the flash).

FYI, it is the driver package (plus sample rootfs) which does the actual flash. JetPack is only a frontend to this.

When the flash stage occurs only the micro-B USB is used. Once this completes the Jetson will reboot.

Upon reboot JetPack will use wired ethernet instead the USB cable. If the Jetson just rebooted from a flash, then there is a mechanism in place to attempt to tell the host PC what the address is. If this fails (not unusual), or if you just want to install packages without flashing again, then you have to manually enter the IP address of the Jetson. You’ll need to monitor the console in JetPack to see when this step is reached. The router will tell you what the address is if you cannot log in to the Jetson itself to determine that.

@linuxdev

Thnkyou for d respond .

The install console did find the IP of target and managed to flash

After reboot then the terminal state
waiting 30 second for device fully awake

Right after that the install terminal close .
And the Jetpack panel turn to successfully installed .

But the target TX2 still not having all the Jetpack package.
The log still appearing the same as before.

Are these behaviour is normal ?

Or should I try with the USB serial instead ?