NVIDIA Jetson GUI Problem After Flashing

Done Flashing as per the User Guide.
http://developer.download.nvidia.com/embedded/jetson/TK1/docs/2_GetStart/Jeston_TK1_User_Guide.pdf

Once board is powered ON, Ubuntu 14.04 LTS opens and then blank screen appears.
http://www.omgubuntu.co.uk/wp-content/uploads/2014/03/wallpaper_blog_post.jpg

I can able to access the board through SSH.

So, I followed general steps and the following are the errors.

ubuntu@tegra-ubuntu:~$ sudo apt-get update
E: Archives directory /var/cache/apt/archives/partial is missing. - Acquire (2: No such file or directory)

ubuntu@tegra-ubuntu:~$ sudo apt-get upgrade
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened

The Command: sha1sum -c /etc/nv_tegra_release => returned all OK.
Then I Followed few more steps based on Previous Forums troubleshooting techniques:

ubuntu@tegra-ubuntu:~$ sudo apt-get install --reinstall unity
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened.

ubuntu@tegra-ubuntu:~$ sudo apt-get install --reinstall ubuntu-desktop
E: Unable to write to /var/cache/apt/
E: The package lists or status file could not be parsed or opened.

ubuntu@tegra-ubuntu:~$ sudo nvidia-xconfig

Using X configuration file: “/etc/X11/xorg.conf”.

WARNING: No Screen specified, constructing implicit screen section.

WARNING: No Layout specified, constructing implicit layout section using screen “Default
Screen”.

WARNING: Unable to find CorePointer in X configuration; attempting to add new CorePointer
section.

WARNING: The CorePointer device was not specified explicitly in the layout; using the first
mouse device.

WARNING: Unable to find CoreKeyboard in X configuration; attempting to add new CoreKeyboard
section.

WARNING: The CoreKeyboard device was not specified explicitly in the layout; using the
first keyboard device.

Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.nvidia-xconfig-original’

ERROR: Unable to write file size for ‘/etc/X11/xorg.conf.backup’ (No space left on device)

So, I had did the following which can give more information to troubleshoot:

ubuntu@tegra-ubuntu:~$ sudo parted -l
Error: /dev/mmcblk0rpmb: unrecognised disk label

Model: MMC SEM16G (sd/mmc)
Disk /dev/mmcblk0: 15.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 256MB 255MB primary boot
2 256MB 15.0GB 14.8GB primary
3 15.0GB 15.8GB 716MB extended
5 15.0GB 15.8GB 716MB logical

ubuntu@tegra-ubuntu:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 12G 12G 0 100% /
devtmpfs 850M 4.0K 850M 1% /dev
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 175M 724K 174M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 874M 76K 874M 1% /run/shm
none 100M 8.0K 100M 1% /run/user
overflow 1.0M 4.0K 1020K 1% /tmp

All these problems are routing to same issue: Disk Full.

Is there any way out?

That guide is a bit outdated, especially when it gives the size “-S 8GiB”. What was the exact flash command you gave? To make all of the eMMC available:

sudo flash.sh -S 14580MiB jetson-tk1 mmcblk0p1

If something other than the above “-S” size, I’d suggest just re-flashing…in which case it’ll just work when done.

You will probably get a better result by using JetPack as described in the document.

@linuxdev:

I had entered the exact command as mentioned in the User manual document.

sudo ./flash.sh -S 8GiB jetson-tk1 mmcblk0p1

After that there was no response so again I entered command like this:

sudo ./flash.sh -S 14580MiB jetson-tk1 mmcblk0p1

After that I reboot then the problem started.
The results after entering your command is:
I did from ubuntu and root users and the results are same.

root@tegra-ubuntu:/home/ubuntu# ls
Desktop    Downloads  NVIDIA-INSTALLER  Public     Videos
Documents  Music      Pictures          Templates

root@tegra-ubuntu:/home/ubuntu# cd NVIDIA-INSTALLER
root@tegra-ubuntu:/home/ubuntu/NVIDIA-INSTALLER# ls

installer.sh  LICENSE  Linux_for_Tegra  README.txt

root@tegra-ubuntu:/home/ubuntu/NVIDIA-INSTALLER#
root@tegra-ubuntu:/home/ubuntu/NVIDIA-INSTALLER# cd Linux_for_Tegra

root@tegra-ubuntu:/home/ubuntu/NVIDIA-INSTALLER/Linux_for_Tegra# ls
apply_binaries.sh  flash.sh         laguna.conf       pm375.conf   source_sync.sh
ardbeg.conf        jetson-tk1.conf  laguna_t124.conf  rootfs       zImage_to_uimg.sh
bootloader         kernel           nv_tegra          shield.conf

root@tegra-ubuntu:/home/ubuntu/NVIDIA-INSTALLER/Linux_for_Tegra# sudo flash.sh -S 14580MiB  jetson-tk1 mmcblk0p1
sudo: flash.sh: command not found

So, I googled and tried few more commands
To verify the permissions for the flash.sh; this states that I have permissions for flash.sh

ubuntu@tegra-ubuntu:~/NVIDIA-INSTALLER/Linux_for_Tegra$ ls  -l  flash.sh
-rwxr-xr-x 1 root root 31121 Oct  8  2014 flash.sh

Checked Environment Path Variables:

ubuntu@tegra-ubuntu:~/NVIDIA-INSTALLER/Linux_for_Tegra$  env | grep ^PATH
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

ubuntu@tegra-ubuntu:~/NVIDIA-INSTALLER/Linux_for_Tegra$ sudo env | grep ^PATH
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

@Kangalow: I tried to install JetPack, I could not able to upgrade/update/install/download because of Disk Full

Did you install JetPack on your Ubuntu PC?

@Kanglow:
I had installed Ubuntu as VM on my Windows. I had not yet installed JetPack. I can install JetPack on Ubuntu VM. After that what to do…?

You can follow the directions in the installation instructions. Here’s what to expect:

http://jetsonhacks.com/2015/03/09/jetpack-1-1-nvidia-jetson-tk1-development-pack/

I was confused when you had a Disk Full error, and now that you note that you had not yet installed JetPack. I’m sure I’m missing part of the story.

People have experienced issues installing from a VM, but they usually have to do with USB handling of the virtual machine. Good luck!

@Kangalow:
I got this. VM Ubuntu is not detecting USB connection of NVIDIA Board. Got to work around & install OS on hard disk. Will post the results - might get delayed…

Place the Jetson into recovery mode, attached the USB serial cable that comes with the Jetson to your PC, and from a Terminal on the PC execute

$ lsusb

You should see the Jetson identified as 0955:7140 Nvidia Corp. or similar.
If you cannot see the Jetson, your VM is blocking access to the USB port. If you’re using something like Virtual Box, you need to use the ‘USB pass through’ feature. VMWare Player has a similar feature. The Jetson must be in recovery mode in order for it to be visible to the PC, and for flashing purposes.

If the PC does not see the Jetson through USB, you will not be able to flash the Jetson.

@Kangalow:
Followed your steps. It worked fine. JetPack is good & easy to use. Need to start working on Jetson now.

I couldnt able to work it with Ubuntu Virtual Box since it couldnt able to identify Jetson through USB connection. I installed Ubuntu on Hard disk and started working.

Got an Error after installation which shows the message box that to send the log file to TegraDeveloperPack-Users@nvidia.com; Log file available in : http://we.tl/HeVIT699AA
I thought there could be a problem, but everything worked fine. Thanks a lot…

Thanks a lot…