Jetson TK1 / L4T / XServer without display

Hi,

Is there any way to run OpenGL/Cuda without physically connected display?

I managed to start XServer using custom EDID, but any sample from Cuda toolkit says that cant find suitable device and create a context.

Try add to screen section in xorg.conf

Section "Screen"
...
Option "UseEdid" "False"
...
EndSection

or you can try Xvfb: http://en.wikipedia.org/wiki/Xvfb

Thanks, will try it.

Also found some display emulation modules:

HDMI dummy plug

CompuLab Display Emulator

excuse me I misunderstand the question ;)

Sorry to revive a ghost thread but…

Did you ever get this working? I am struggling to achieve this myself.

I can get some samples to run (eg: NVIDIA_CUDA-7.0_Samples/2_Graphics/simpleGL/simpleGL) by doing the following in my SSH session:

ubuntu@tegra-ubuntu:~$ export DISPLAY=:0
ubuntu@tegra-ubuntu:~$ NVIDIA_CUDA-7.0_Samples/2_Graphics/simpleGL/simpleGL
simpleGL (VBO) starting...

But carrying on with more complex programs that use QT or other OpenGL objects will have issues, EG the ZED (Stereo camera) Depth viewer:

ubuntu@tegra-ubuntu:/usr/local/zed/tools$ "./ZED Depth Viewer"
Segmentation fault

However if I physically plug in a screen it will run and display on the screen. I can then also disconnect the screen and it will still run. Looking at the xconf log I found the following event when plugging in the screen:

[   249.822] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   249.823] (**) NVIDIA(0):     device Philips 170S (DFP-0) (Using EDID frequencies has
[   249.824] (**) NVIDIA(0):     been enabled on all display devices.)
[   249.961] (II) NVIDIA(0): Setting mode "NULL"
[   250.140] (II) NVIDIA(0): Setting mode "HDMI-0: 1280x1024_60 @1280x1024 +0+0 {ViewPortIn=1280x1024, ViewPortOut=1280x1024+0+0}"

Any ideas? I am about to crumble and buy the emulation module…

Here’s something to try. There is a hardware option, and a software option:
http://jetsonhacks.com/2016/05/03/jetson-allow-graphics-without-hdmi/

The software option is:

Edit /etc/X11/xorg.conf

Section "Device"
...
...
Option "AllowEmptyInitialConfiguration" "true"
EndSection