Jupyter lab error

hello, I can’t use the jupyter lab on my jetson nano,
I use the jetpack4.4 on my jetson nano and I use this code to install jupyter lab on my jetson nano:

sudo apt update & sudo apt install nodejs npm
sudo pip3 install jupyter jupyterlab
jupyter lab --generate-config
jupyter notebook password

According to the installation tutorial I refer to, after doing so, I can use jupyter lab to enable jupyter lab: this is the tutorial I according

after I install the jupyter lab , I use jupyter lab to start using the jupyter lab

and then, Then, a python error occurred:

Traceback (most recent call last):
  File "/home/dlinano/.local/bin/jupyter-lab", line 11, in <module>
  File "/home/dlinano/.local/lib/python3.6/site-packages/jupyter_core/application.py", line 270, in launch_instance
    return super(JupyterApp, cls).launch_instance(argv=argv, **kwargs)
  File "/home/dlinano/.local/lib/python3.6/site-packages/traitlets/config/application.py", line 663, in launch_instance
  File "<decorator-gen-7>", line 2, in initialize
  File "/home/dlinano/.local/lib/python3.6/site-packages/traitlets/config/application.py", line 87, in catch_config_error
    return method(app, *args, **kwargs)
  File "/home/dlinano/.local/lib/python3.6/site-packages/notebook/notebookapp.py", line 2037, in initialize
  File "/home/dlinano/.local/lib/python3.6/site-packages/notebook/notebookapp.py", line 1629, in init_webapp
    self.tornado_settings['allow_origin_pat'] = re.compile(self.allow_origin_pat)
  File "/usr/lib/python3.6/re.py", line 233, in compile
    return _compile(pattern, flags)
  File "/usr/lib/python3.6/re.py", line 301, in _compile
    p = sre_compile.compile(pattern, flags)
  File "/usr/lib/python3.6/sre_compile.py", line 562, in compile
    p = sre_parse.parse(p, flags)
  File "/usr/lib/python3.6/sre_parse.py", line 855, in parse
    p = _parse_sub(source, pattern, flags & SRE_FLAG_VERBOSE, 0)
  File "/usr/lib/python3.6/sre_parse.py", line 416, in _parse_sub
    not nested and not items))
  File "/usr/lib/python3.6/sre_parse.py", line 616, in _parse
    source.tell() - here + len(this))
sre_constants.error: nothing to repeat at position 0

(this is the frist topic I create,and my english is very bad.so…If there is any information that I need to add, please post it under this topic, I will add it as soon as possible, thank you very much)

Have reference to below topic.

So do I need to use jetcard to install Jupyter Lab on my jetson nano?

I don’t think these instructions are relevant to JP4.4. I’ve tried following these instructions as well as going to the Github repo and following the instructions from there (it’s the same thing). I get errors at the end of the installation, and when I try to run “jupyter lab --configure” it comes back with an error. I’ve tried following these instructions time and again on JP4.4, but I’m either doing something wrong or the instructions need updating.