Laggy touchpad Zephyrus M16 Ubuntu 20.04 Nvidia

Hey guys.

I recently bought a Zephyrus M16 with i7 12700H and RTX 3060. I’ve been having problems with configuring some linux distribution on it.
I tried to install several distros and found common problems between them:

  1. Screen flickers when I move the mouse/touchpad. After moving a lot, the screen goes out and only comes back after turning off.
  2. When this doesn’t happen to the screen, the mouse is extremely slow.

I currently have Ubuntu 22.04 installed, card driver version 525 and I find myself in the second problem. I put an external monitor and it works perfectly, but the computer screen is slow as I reported. The notebook screen is set to 175HZ, I can’t lower it because it’s the only frequency the system offers me. The monitor is at 60hz working perfectly.

Can anyone help me?


1 Like

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I‘m having the same problems with the Zephyrus M16. Is there any solution that worked for you @yagogmaia ?
@generix here is my Thank you for your help in advance
nvidia-bug-report.log.gz (301.3 KB)

The kernel modules are not installed. Please reinstall the kernel headers
sudo apt install --reinstall linux-headers-$(uname -r)
and post the output of
dkms status

I run the command but the error didn’t get solved. No package got installed and the dims status showed the Nvidia/525.85.05 package installed (I apologize for posting a phone image of the terminal instead of a screenshot. It‘s difficult to move in gnome right now with all the delay of the mouse)

I started Ubuntu with the previous kernel version 5.19.0-32 to see if the kernel update was the problem, but I got the following error at the beginning:

This also happened in the current kernel 5.19.0-35 one time when the problem started, then the error disappeared after reboot but the problems remained

You were missing a space in the command I gave
sudo apt install --reinstall linux-headers-$(uname -r)

The error you got when booting into the old kernel looked like the nvidia gpu might have some additional issues.
Please switch to on-demand mode
sudo prime-select on-demand

I did:
Removed all nvidia drivers:
sudo apt-get remove --purge nvidia-*

I started ubuntu by setting nomodeset in grub:

I installed the proprietary drivers version 525

I performed the following steps:

And my GRUB_CMDLINE_LINUX_DEFAULT looked like this:
“quiet splash nvidia-drm.modeset=0 usbhid.mousepoll=1 i915.enable_psr=0 ibt=off”

With that everything worked normally. I now have an error in the speaker, when I lower the volume it seems that it only reduces the treble.

Thank you a lot! It worked!

@yagogmaia please let me know if you found a solution for the speaker problem. I got the same problem now as well

I achieved!

I followed these steps and it worked perfectly. Let me know if you got it.

It worked perfectly! @yagogmaia thank you a lot!
Not sure if we can give digital awards here in the forum but you deserve one :-)

There’s nothing to thank, I’m happy to help.
I spent days trying to configure my notebook with linux to work.

I have a doubt, are you Brazilian?