Linux Kernel 4.14.33 (on Amazon Linux) doesn't seem to install drivers correctly

I’m trying to build a new environment on AWS EC2 using their newest AMI, which uses kernel 4.14 (as of late April). I’ve had no problems in the past installing and running on their previous iteration, which used kernel 4.9. I’m assuming the kernel is the problem, but I can’t be sure.

I tried using the 375.66 driver, since that has been what we’ve been using. I also tried the more recent 384.66, but also to no avail.

When I try to build, I get these errors in sequence:

ERROR: An error occurred while performing the step: "Building kernel modules". See /var/log/nvidia-installer.log for details.

ERROR: An error occurred while performing the step: "Checking to see whether the nvidia-uvm kernel module was successfully built". See /var/log/nvidia-installer.log for details.

ERROR: The nvidia-uvm kernel module was not created.

ERROR: The nvidia-uvm kernel module failed to build. This kernel module is required for the proper operation of CUDA. If you do not need to use CUDA, you can try to install this driver package again with the '--no-unified-memory' option.

ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

I’m attaching the installer log. Is this a common problem?

nvidia-installer.log (74.4 KB)

Probably driver too old. Try with 384.130 or a 390.x driver.

https://http.download.nvidia.com/XFree86/Linux-x86_64/

That was stupidly simple. Thanks! I was picking an older driver based off cuda 8.0. Guess I just need to use a newer cuda.