Linux KVM Live Migration for Tesla T4 Problem

Hello

I can live migrate on the NVIDIA T4 graphics card, but after the migration is completed, the Linux kernel reports the following error. What is the reason?

Nov 24 19:30:38 VM-0-76-centos nvidia-vgpu-mgr[23405]: notice: vmiop_log: (0x0): Finish restoring vGPU state …

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: NVOS status 0x19

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: Assertion Failed at 0xe7c0bd31:150

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: 5 frames returned by backtrace

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: /lib64/libnvidia-vgpu.so(_nv004938vgpu+0x26) [0x7fa50af0de76]

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: /lib64/libnvidia-vgpu.so(+0x7a901) [0x7fa50aeab901]

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: vgpu(+0x10d31) [0x55b8e7c0bd31]

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: /lib64/libpthread.so.0(+0x814a) [0x7fa50ba3314a]

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: /lib64/libc.so.6(clone+0x43) [0x7fa50b356dc3]

Nov 24 19:30:39 VM-0-76-centos nvidia-vgpu-mgr[23405]: error: vmiop_log: (0x0): Failed to create local Memory handle (error: 0x19)

Dev environment
Linux Host :CentOS 8.3
Nvidia Grid: 12.2
Guest OS :Window 10

Thks

Hi,

you may try the current vGPU version for this branch. Apart from that there is not much we can do as you are running a not supported configuration (CentOS) so you won’t be able to open a support ticket with NVES.

regards
Simon