Manually startx command needed after nvidia-driver-390 installation on Linux Mint 19.1

Hi there.

I know there’s a bunch of topics like this, but none of them solved my problem (and I did read a lot of them).

So I’m coming from windows 10, interested in know more about other OS. I’m trying to use LM four about 3 days, but I can’t. I installed LM 19.1 Cinnamon and my problem is:

when I install the nvidia-driver-390, things go well: no (apparent) errors, normal installation, etc. I’m asked about the password for the next’s boot MOK key enroll. OK. But, after I reboot, enroll the key and go on, I pass through the LM splash and then the screen goes black.

The laptop remains up so I do Ctrl+Alt+F1. I type startx and that’s it. The OS boot normally. But, after the nvidia driver installation I have to this step (manually startx) in every single boot. This kinda sucks.

As I said, I read a bunch of stuff about this problem. So I gathered as many info as I could. I’m linking a .tar.bz2 file which contains a README that explains all the information about the data gathered. This like also contains nvidia-bug-report log file.

My system is a dell inspiron 14 3443, with core i5 5200u, intel HD graphics 5500 and a geforce 820m.

Since now I’d like to thank everyone who is going to help me for the attention and efforts!

link to the .tar.bz2 file: https://ufile.io/cit3y

Looks like the command to enable prime output went awol in lightdm. Please check if
sudo dpkg-reconfigure lightdm
and a reboot helps. Otherwise add it manually like described here:
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Display_Managers

Oh, thanks!

I guess it’s important to state that the nvidia-driver-390 didn’t generated the xorg.conf in /etc/X11/ directory. So, in the meanwhile I figured out that nvidia-xsettings is supposed to do just that, so I ran the command.

After that my session freezes. I can login through another tty. So, should I delete the xorg.conf and do what you say or shoukd I keep the xorg.conf file generated by nvidia-xsettings and do what you suggested?

BTW, thank you for your attention!

It’s an Optimus system, meaning that the display is connected to the intel gpu so the output from the nvidia gpu has to be routed through that. So a simple xorg.conf breaks it. Please delete it, the needed config snippets are generated by gpumanager.

First, thank you for the explanation!

Second:

good news! It kinda works now… But now the login form stays in loop. I login, it validates an then returns to the login again.

Any ideia?

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Ok, there it is!
nvidia-bug-report.log.gz (351 KB)

Oh, just for the records.

In the Arch wiki link you posted I saw the following:

Now configure lightdm to run the script by editing the [Seat:*] section in /etc/lightdm/lightdm.conf

/etc/lightdm/lightdm.conf
[Seat:*]
display-setup-script=/etc/lightdm/display_setup.sh

But that files doesn’t exist in my system, so I created (assuming I’m already on /etc/lightdm):

sudo nano lightdm.conf

ah then added the lines

[Seat:*]
display-setup-script=/etc/lightdm/display_setup.sh

I thought it was important to clarify that the /etc/lightdm/lightdm.conf file wasn’t in me fs before.

Ok, had to look up which files the Mint/Ubuntu packages installs. There seems to be a problem with Mint currently:
https://devtalk.nvidia.com/default/topic/1047200/linux/black-screen-after-installing-nvidia-driver-on-linux-mint-19-1/
is the same problem.

Please remove the file /etc/lightdm/ligtdm.conf, then please make sure that the package nvidia-prime is installed, reinstall it using
sudo apt-get --reinstall nvidia-prime
Please post the version that gets installed. Afterwards, check that the file /usr/share/lightdm/lightdm.conf.d/90-nvidia.conf exists. Run
sudo prime-select nvidia
and reboot.
If it still doesn’t work, please attach the lightdm log (/var/log/lightdm/lightdm.log ?)