Login Loop after installing Nvidia proprietary drivers Ubuntu 19.10

I am get stuck in the (in)famous login loop after installing nvidia gpu drivers. I have Ubuntu 19.10, intel cpu, and nvidia geforce 1070 gtx (M).
nvidia-bug-report.log.gz (389 KB)

I’m getting this on the driver installation:

nvidia.ko:
Running module version sanity check.
modinfo: ERROR: missing module or filename.
 - Original module
   - No original module exists within this kernel
nvidia-modeset.ko:
Running module version sanity check.
modinfo: ERROR: missing module or filename.
 - Original module
   - No original module exists within this kernel
 - Installation

nvidia-uvm.ko:
Running module version sanity check.
modinfo: ERROR: missing module or filename.
 - Original module
   - No original module exists within this kernel

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Done, thanks!

Now that’s a bit weird, the driver loads fine but this looks like there are two Xservers started at the same time. Did you change anything regarding systemd units recently?
Please do a system update first and check if that resolves the issue.
If not, please check what starts up when you disable the display-manager:
sudo systemctl disable display-manager
After a reboot, you should end up on a text console. Log in, run
sudo systemctl start gdm
The gdm login should come up, does it work then?
You can re-enable the display-manager using
sudo dpkg-reconfigure gdm

No, it´s a fresh installation.

The sudo systemctl disable display-manager doesn’t work.

I still get stuck at the login loop. (i choose to logon without a password on boot)

When i do a sudo systemctl stop gdm at text console ty3 and after a sudo systemctl start gdm, the xserver starts ok showing the keyring password popup, but system freezes.

Really strange.

Weird. Please post the output of
systemctl list-unit-files | grep enabled

snap-core-7917.mount                       enabled        
snap-core18-1223.mount                     enabled        
snap-gnome\x2d3\x2d28\x2d1804-71.mount     enabled        
snap-gnome\x2dcalculator-501.mount         enabled        
snap-gnome\x2dcharacters-317.mount         enabled        
snap-gnome\x2dlogs-81.mount                enabled        
snap-gtk\x2dcommon\x2dthemes-1353.mount    enabled        
acpid.path                                 enabled        
apport-autoreport.path                     enabled        
cups.path                                  enabled        
accounts-daemon.service                    enabled        
anacron.service                            enabled        
apparmor.service                           enabled        
autovt@.service                            enabled        
avahi-daemon.service                       enabled        
bluetooth.service                          enabled        
console-setup.service                      enabled        
cron.service                               enabled        
cups-browsed.service                       enabled        
cups.service                               enabled        
dbus-fi.w1.wpa_supplicant1.service         enabled        
dbus-org.bluez.service                     enabled        
dbus-org.freedesktop.Avahi.service         enabled        
dbus-org.freedesktop.ModemManager1.service enabled        
dbus-org.freedesktop.nm-dispatcher.service enabled        
dbus-org.freedesktop.resolve1.service      enabled        
dbus-org.freedesktop.thermald.service      enabled        
dbus-org.freedesktop.timesync1.service     enabled        
dmesg.service                              enabled        
e2scrub_reap.service                       enabled        
getty@.service                             enabled        
gpu-manager.service                        enabled        
grub-initrd-fallback.service               enabled        
irqbalance.service                         enabled        
kerneloops.service                         enabled        
keyboard-setup.service                     enabled        
lm-sensors.service                         enabled        
ModemManager.service                       enabled        
network-manager.service                    enabled        
networkd-dispatcher.service                enabled        
NetworkManager-dispatcher.service          enabled        
NetworkManager-wait-online.service         enabled        
NetworkManager.service                     enabled        
ondemand.service                           enabled        
openvpn.service                            enabled        
pppd-dns.service                           enabled        
rsync.service                              enabled        
rsyslog.service                            enabled        
secureboot-db.service                      enabled        
setvtrgb.service                           enabled        
snapd.autoimport.service                   enabled        
snapd.core-fixup.service                   enabled        
snapd.seeded.service                       enabled        
snapd.service                              enabled        
snapd.system-shutdown.service              enabled        
switcheroo-control.service                 enabled        
syslog.service                             enabled        
systemd-fsck-root.service                  enabled-runtime
systemd-remount-fs.service                 enabled-runtime
systemd-resolved.service                   enabled        
systemd-timesyncd.service                  enabled        
thermald.service                           enabled        
udisks2.service                            enabled        
ufw.service                                enabled        
unattended-upgrades.service                enabled        
whoopsie.service                           enabled        
wpa_supplicant.service                     enabled        
acpid.socket                               enabled        
apport-forward.socket                      enabled        
avahi-daemon.socket                        enabled        
cups.socket                                enabled        
snapd.socket                               enabled        
uuidd.socket                               enabled        
remote-fs.target                           enabled        
anacron.timer                              enabled        
apt-daily-upgrade.timer                    enabled        
apt-daily.timer                            enabled        
e2scrub_all.timer                          enabled        
fstrim.timer                               enabled        
logrotate.timer                            enabled        
man-db.timer                               enabled        
motd-news.timer                            enabled        
snapd.snap-repair.timer                    enabled

No idea. I think you should try a reinstall and if that doesn’t work, revert to 19.04 and report to Ubuntu since 19.10 has just been released.

Maybe this is a new gdm bug, you could also just revert to lightdm.

It’s the second time I have reinstall.

Worked! Thank you so much! you’re the man!
;)

I have just reinstalled the gdm3 and worked!