Ubuntu 18.04 login loop

Hello,
We are experiencing the login loop problem, presumably after the last system update.
Everything was working fine (driver, CUDA and CuDNN is installed) until last system upgrade, but now something broke. I already tried common solution found googling like permission on /tmp folder and .XAuthority (which is not existing), then when I tried nvidia-smi I got error: NVIDIA - SMI has failed because it couldn’t communicate with the NVIDIA driver . Make sure that the latest NVIDIA driver is installed…" so now I think that some part of the upgrade broke nvidia driver…
Attached the nvidia-bug-report. Any help?

nvidia-bug-report.log.gz (62.4 KB)

How did you install the driver?
please post the output of
dkms status

Hi, at the end I solved my problem.
That was not my computer so it was a little bit tricky to undestand what they did… Anyway I realized the driver was installed using the .run installer a couple of years ago, while there was a recent system upgrade. I think since the driver was never updated a 2-year mismatch between driver and xorg packages version was the caused the issue. I first uninstalled the driver using nvidia-uninstall , this gave me warnings about driver installation altered and about it cannot restore the original xorg configuration (backup was not made). Loop persisted. Then I deleted /etc/modprobe.d/blacklist-nvidia-nouveau.conf that was created according to https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-nouveau-ubuntu. Loop persisted. At this point i realized that there was another file blacklisting nouveau and was /etc/modprobe.d/nvidia-installer-disable-nouveau.conf I deleted that file too… reboot and GUI was back with nouveau.
I then installed latest driver using sudo ubuntu-drivers autoinstall and now everything is working!