Ubuntu 18.04 login loop after driver install

Hi, I’m working on a Dell Precision 5530 on a Ubuntu 18.04 and I cannot get past the login loop after installing nvidia drivers (by using ubuntu-drivers autoinstall for 390 or by using the ppa and the 418 driver).

I will attach the nvidia-bug-report.log, maybe someone can help.

I also tried following the steps described here https://devtalk.nvidia.com/default/topic/1043405/linux/ubuntu-18-04-headless_390-intel-igpu-after-prime-select-intel-lost-contact-to-geforce-1050ti/post/5293003/#5293003 and could login but when checking the System -> About it still shows the Intel Card (even though nvidia-prime query returns nvidia)
nvidia-bug-report.log (1.31 MB)

Please remove the kernel parameter ‘nomodeset’

I do not have the ‘nomodeset’ parameter on the kernel when starting normally, as you can see from this output:

azapartan@azapartan:~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.18.0-16-generic root=UUID=aaa8f042-c49f-4229-baef-f1338070be1e ro quiet splash vt.handoff=1
azapartan@azapartan:~$

that was set only when I booted in recovery mode in order to remove the driver so I could login using the nouveau. As a mention, it used to work correct with nvidia-driver-390 for a while but I had to reinstall the driver due to a external monitor not being recognized anymore and since then I have the login loop issue.

Ok, please create a new nvidia-bug-report.log from a normal boot.

Ok I added the log generated right after driver install using ubuntu-drivers autoinstall , which resolved to nvidia-390 and also the log generated after reboot (I had to generate it from the non-gui interface)
nvidia-bug-report-after-install-NO-reboot.log.gz (577 KB)
nvidia-bug-report.log.gz (586 KB)

Please run
grep modeset /etc/modprobe.d/* /lib/modprobe.d/*
to find the file containing
options nvidia-drm modeset=1
and change it to
options nvidia-drm modeset=0
then run
sudo update-initramfs -u
and reboot.
Also, run
sudo journactl -b0 --no-pager _COMM=gdm-x-session >journal.log
after trying to log in and attach that.

Thanks a lot for the suggestions!, now it works. Just did the steps and I was able to login and now the correct device is shown on the About info. I also ran the log command and I’ll attach it here.
Thanks again!
journal.log (83.2 KB)

I experienced the same problem with Ubuntu 18.10. I have installed 19.04 and the same happens - see https://ubuntuforums.org/showthread.php?t=2411777&page=2&p=13860763#post13860763

Please open a new thread.
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I experienced a similar issue just now while trying to install Ubuntu 18.04 LTS on a system with two Titan RTX cards. The install process went fine - I selected third-party drivers to be installed as part of the process and provided the UEFI secure boot password, etc. The nvidia driver that was installed automatically was version 430.

After rebooting, the system came up but I was not able to login - got stuck in a login loop. Shutting down the system and waiting a few minutes before rebooting would result in the system somehow deciding to go with the default neuveau video driver and would allow me to login but the nvidia-smi command would still result in errors indicating that the nvidia driver was not functioning. After reinstalling the system a few times with different kernels and all sorts of other attempts at installing various nvidia drivers going all the way back to 410, I was at a loss. None of the suggestions in this thread or others that I found on the web worked at all.

The solution that worked for me was very obscure. Just by trial and error, I was going through BIOS boot settings on my motherboard (ASUS WS X99) and noticed that there was a UEFI option in the secure boot section that by default had Windows selected. I changed that to “Other OS” and rebooted - I was able to login and ran nvidia-smi - all looks good.

I spent about 6 hours tracking this down. Hope this post helps someone with the same or similar issue.

I created an account just to confirm, this (+ this) fixed my issue with enabling the Quadro P1000 on my Dell 5530 w/ 18.04.5 causing the login loop.