Can't login to Ubuntu 18.04 after installing driver 435.21

Today i have installed Ubuntu 18.04 on my laptop ASUS-Zenbook.
I used Ubuntu GUI in order to install the nvidia driver, version 435.21 (following this guide https://www.linuxbabe.com/ubuntu/install-nvidia-driver-ubuntu-18-04).

After reboot when i try to login i’m stuck at black screen.
When i switch to text mode (Ctrl+F3) i can see the driver installation went well - nvidia-smi returns valid output.

nvidia-bug-report.log is attached
nvidia-bug-report.log.gz (1.52 MB)

I’ve been fighting with this as well after upgrading my desktop with arch linux to use 435.21 drivers. My desktop has been dead for a month as I can’t figure out how to fix this, and any effort, including downgrade kernel/drivers, hasn’t worked for me. This is with KDE, Cinnamon, Mate, any desktop manager to launch them.

The common thing I’ve found, as I was troubleshooting KDE crashes leading up to this is suddenly my video card wants to launch in EGL mode using GL ES 2.0 drivers vs. the normal GL rendering under linux desktop.

I’ve got a thread I’ve been forming to post here for help, but a broken foot has stunted my giving much of a darn for now, and just use my laptop.

That said, I’m afraid to upgrade my laptop, or any packages on it, after it seems Nvidia has bricked my desktop here mostly.

@mikus
So do you have any recommendation to me ?
I also tried the 430 driver and got same results.

yossib, it’s an Optimus notebook, so you can’t use the .run installer.
Please follow this:

  • remove the .run installer driver using the --uninstall option
  • remove /etc/X11/xorg.conf
  • install the driver from repo (sudo apt install nvidia-driver-430)
  • install nvidia-prime (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.
2 Likes

Thank you so much, it did solve the problem.

Hello!
I have the same problem.
My ubuntu 18.04 not start GUI after CUDA installation.
However I have ssh connection with my ubuntu.
Here is attached the bug report.
nvidia-bug-report.log.gz (1.1 MB)