Login loop on new installation Ubuntu 17.10 using NVIDIA GTX 1070

This is dual boot desktop with a brand new installation of Ubuntu 17.10 where the login cycles in an endless loop.

I am positive the system works as I can use it when booting on Windows 10 and the NVidia card performs as expected.

After researching multiple forums, this is the summary of the current system configuration

  • Integrated Intel GPU disabled in BIOS
  • nomodeprobe setting on GRUB default command line
  • Clean installation of Ubuntu 17.10 with latest updates as Dec 18, 2017
  • removing GDM3
  • installing Unity and Lightdm
  • login using Xorg instead of Wayland
  • installing the nvidia driver 384.98 using:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-384

  • Trying using “Ubuntu on Xorg” and “Unity”, the outcome is the same, the login screen reappears.

I am attaching the output from the nvidia bug collector script and the journalctl output.

Lastly, I tried with Ubuntu 16.04.3, and the outcome is the same.

Much help appreciate it…

ubuntu-17_10-GTX1070-login-loop.tar.gz (78.7 KB)
nvidia-bug-report.log.gz (46.9 KB)
journalctl_ubuntu-17_10-GTX1070-loop.txt.tar.gz (34.7 KB)

There’s no trace that the kernel driver even tries to load. Please post the output of
grep blacklist /etc/modprobe.d/*
cat /var/log/gpumanager.log

Just noticed you’re running a signed kernel, so secure boot is enabled. Disable this as the nvidia kernel module is unsigned thus cannot be loaded.

That was exactly the culprit of the issue. Now I can see pass the login screen and see the actual desktop running with the nvidia driver.

Thanks a lot for your help!

I am happier today :-)

Happy holidays


I’ve ran into the same issues, and tried to solve with the same potential solutions, but that did not work.

So regarding disabling secure boot, in which order should that be done? Do you do the following?

  1. install ubuntu 17.10
  2. disable secure boot
  3. install nvidia drivers

This is what I tried and that did not work unfortunately. Does that need to be done in a different order?

This is the order I followed:

  1. disable secure boot
  2. install ubuntu 17.10
  3. install nvidia drivers

Happy new year!!!

As a note, Ubuntu 17.10 and Nvidia drivers worked so the main login and desktop problem is solved, however when installing CUDA, the prerequisites are out of bounds when using Ubuntu 17.10 so the CUDA installation fails, so I decided to go with the Ubuntu 16.04 LTS and life is good now. Disabling the secure boot still applicable though.


It works! Thank you so much, as I spend the last 2 days on this issue.

And good to know about CUDA. I don’t think I will need it, so I’ll try and stay on 17.10 for now, but thank you for letting me know.

Happy new year indeed!