Nvidia Login loop on Ubuntu

I’m on a mid 2014 MacBook Pro with nVidia GeForce GT 750M
GPU with 2GB of dedicated GDDR5

Running Ubuntu 18.04 on an external Hard Drive

After installing CUDA 10.02 (maybe it wasn’t compatible?)


This is exactly how I installed, got no issues till the reboot.

On reboot I got a login loop and I know there are many topics here on that but I can’t follow them because I can’t get into a command prompt of any kind.

I’ve tried a few commands like Ctrl+Alt+F1, nothing happens. When I do ‘Ctrl+Alt+Fn+F3’ I get a blank screen and I can’t seem to get out of it using Ctrl+Alt+Fn+F7
Not sure how I could get any logs of what’s going on.

PS. I’m new to Ubuntu/Linux

this is known bug. Remove splash option from grub menu and see if it is help

Okay, how exactly do I do that? (If another posts explains it well feel free to link me)

Do you have grub menu counting 10 sec usually in a beginning of boot? If no you have to press shift to get into grub menu. Then choose very first line and press “e”. Find word “splash” and delete it. Them press F10 to boot into OS

Okay thank you very much I will let you know how it goes shortly


This is the screen I eventually came to right before deleting ‘splash’ my cursor/underscore is on it in the picture

I had to press shift space and then esc quickly. If I pressed just esc it takes me to a terminal-like grub menu. (Which is good to know)

I tried it twice but no luck. Same login loop

Well… You have to disable autologin then. Check on your keyboard what keys are framed with white or blue color. Same as “fn” key. If F1. F2. etc are framed then you have to use Fn key but if they are not then just press ctrl+alt+F2 to go to TTY 2 login. And from there disable autologin. I don’t remember right now how to do it, but google with help you indefinitely. :)

I found a few resources online but I can’t get into a tty mode of any kind. I get a black screen and I saw this one tutorial that said to start doing commands but I don’t think my commands are responding because ‘reboot’ did nothing


Also this is my keyboard

If theres a way to do it from the grub menu? I’m pretty sure i could get that to work

There are some more problems you’re running into.
The GT750M is most likely a Kepler Mobile gpu, those are officially out of support after driver version 418, meaning:

  • Graphics still works with latest 440 driver
  • Cuda only works up to v10.1 with the 418 driver
  • The 418 driver does not complile with newer kernels.
  • installing full ‘cuda’ is not recommended since it overwrites the repo driver

You should first do a clean reinstall of Ubuntu 18.04 and then decide which cuda version to use and how to install, either

  • use 390 repo driver and cuda-toolkit 9.0
  • don’t upgrade kernel and use cuda-10.1 with bundled 418 driver

Okay, thank you I will do that then. But then I wonder will I have this same issue even with a downgrade?

I don’t know, since I also don’t know what exactly happened. After reinstall, please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).
Only then I can see the complete hardware configuration of your system.

Do not use autologin in new install and you will be safe from loop

1 Like

Reinstalled Ubuntu.

(it only says MacBook Air because I have to initially install on a Macbook Air but after the initial setup, I plug the harddrive into my MacBook Pro

swimnbird@swimnbird-MacBookAir:~$ sudo -i
[sudo] password for swimnbird: 
root@swimnbird-MacBookAir:~# nvidia-bug-report.sh

nvidia-bug-report.sh will now collect information about your
system and create the file 'nvidia-bug-report.log.gz' in the current
directory.  It may take several seconds to run.  In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module.  While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

Please include the 'nvidia-bug-report.log.gz' log file when reporting
your bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to 'linux-bugs@nvidia.com'.

Running nvidia-bug-report.sh...ls: cannot access '/proc/driver/nvidia/./gpus/': No such file or directory


If the bug report script hangs after this point consider running with
--safe-mode and --extra-system-data command line arguments.

 complete.

Haven’t installed much Nvidia stuff yet (other than Nvidia 390 driver metapack in my software and updates) so the bug report didn’t work I think. If it did, I don’t know where the log saves. I’m very new to this.

To do what I’m trying to do I need CUDA 9.2, I know that when I just do the terminal install for CUDA I get version 9.1 and I don’t want any errors if I’m going to install 9.2 later (if I can). I’ve had to restore this drive about 7-9 times for various different reasons, this cuda thing just being the newest reason.

Can I get CUDA 9.2?

It’s called nvidia-bug-report.log.gz and should be in your home directory.

cuda 9.2 needs driver 396. 390 is cuda 9.1 max.

Hmm, I don’t see nvidia-bug-report.log.gz in there, and searching for it nothing is found

You used sudo -i so it’s in root’s home dir. Don’t use options you don’t understand.

I’m doing the my best to follow along with what you’re suggesting.That was the only command I found that seemed to work, like I said, this is all brand new to me.
Anyways, I found it but it won’t let me upload it here because of size, anywhere specifically I should upload it to?

Did you unzip it or simply changed the file extension to “.log”
Otherwise, use google drive or the like.