memory errors on GTX 280

Hi,

The GTX 280 (made by XTX) card I am using for CUDA development is producing lots of errors using the memtestg80 (https://simtk.org/home/memtest/) tool. I tried with different drivers, OS-es but the memory errors are reproducible everywhere (see attached the output for 100 test iterations over 900 MB of memory). Moreover, the weird thing is, that during the test iterations the number of errors seems to slightly increase. Even more interesting is the fact that when I downclocked the memory to 1000 Mhz, I got ~7.5 times less errors and at around 940 Mhz I got ~150 times less errors then initially.

Has anyone seen similar behaviour? I wonder whether only this particular card is faulty or maybe GTX 280s are generally more unstable?

Cheers,
Szilard

PS: the XTX GTX 280 is the standard not the factory-tuned version.
memtestG80_gt280_linux.txt (71.4 KB)

GTX280 is quite stable, while MemtestG80 is still in it developing stage. Have you ever passed the test? Try the default option first (128MB) to see what happen.

I’ve found that there is a limitation with MemtestG80: it cannot test the whole device memory since parts of the GPU memory are reserved for display control.

Yes indeed, memtestg80 is in development stage and it has its limitations, however, 3 GTX 260 cards on various OS-es show no problems at all while this particulat GTX 280 both on widows and linux shows similar behavior.
I think the amount of memory you test is pretty much irrelevant as long as errors are detected - but I tried with both small and larger amounts of memory.

I have two GTX 280 cards, one made by EVGA and one made by PNY. Both are running at the standard clock rate and both pass memtestG80 with a test size of 970MB. I think you might have a faulty card.

Thanks for the feedback seibert!