Mint 18 ssh -X won't display with nvidia driver but does work with xserver driver

Nvidia drivers replicated with: 340.96,367.44 and beta 370.28
open source driver that works fine though slower than molasses: xserver-xorg-video-nouveau 1:1.0.12-build2

issue:
I have Mint 17.1 desktops that can ssh -X to my server just fine and run our program perfectly. I installed a new machine with Mint 18 and everything works perfectly as the Mint 17.1 machine except passing this program over ssh. The error that throws
"
is:Operating system: Linux/Unix
Total screen width height 1920 1080
Single monitor detected
Screen 1 width height x y: 1920 1080 0 0
Machine endian: little
Byteswapping not activated by compiler
Tcl/tk version 8.5.13
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Value in failed request: 0x0
Serial number of failed request: 1967
Current serial number in output stream: 1968"
"

I’ve scoured the web for this. It only happens on Mint 18 with the Nvidia drivers. I’ve pulled the nvidia-bug-report and have it available to look at.

questions: Is there a know fix or workaround for this or is it a known bug? Is there a way to help troubleshoot this? I need to work towards moving everyone to Mint 18 due to some internal policies and the functionality Mint18 gives towards those that Mint17 doesn’t but running programs over ssh is critical to our work. The machine that users ssh in to is a Dell server running Centos6.6. The only video card in the server is the onboard card. The drivers are up to date as much as Dell supports since it is a server and not used for graphics. The workstations are using either K4000 or K2000 cards and the laptops are using 840M cards.

Any help is appreciated or a simple, “You’re never going to get it to work” will help tremendously.

update: I’ve tested this same setup in Mac’s VMware Fusion. I installed the same Mint 18 desktop but using the default vmware drivers with vmwar-tools installed. ssh -X works perfectly fine as well. It is only with nvidia drivers it appears to have issues.
nvidia-bug-report.log.gz (151 KB)

bump. I can’t be the only person in the world experiencing this. Any help in troubleshooting directions would be helpful

It’s because indirect GL is disabled by default in newer X servers. You need to add +iglx to your X server command. See: http://askubuntu.com/questions/745135/how-to-enable-indirect-glx-contexts-iglx-in-ubuntu-14-04-lts-with-nvidia-gfx

Thanks for the reply. I’m showing my LInux lack of knowlege here but I don’t have that file under lightdm.conf.d. I only have 90-nvidia.conf. Can I add that file or does this mean that I don’t have my system set up normally?

I figured out that mint 18 uses mdm as default. I tried to install lightdm but it won’t even let me log in. I removed lightdm and am at least able to log in again. I’m going down the path now to figure out how to set +iglx using mdm.

I figured out that mint 18 uses mdm as default. I tried to install lightdm but it won’t even let me log in. I removed lightdm and am at least able to log in again. I’m going down the path now to figure out how to set +iglx using mdm.

So far re-starting X with +iglx isn’t working. The remote server i’m trying to run the program from doesn’t have any desktop environment installed. It’s Centos 6.6 basic GUI. I guess maybe I’m confused on where the +iglx needs to be set, on the server (not running an Nvidia card) or on the client (mint 18 running Nvidia card) or both?

It would be sent on whichever side is running the X11 server, which in your case should be the Mint 18 machine with the Nvidia card which is actually displaying the window.

I’m assuming you’re running the client X11 program on your CentOS 6.6 server over SSH and displaying through the X11 server on your Mint 18 machine.

I’m assuming you’re running the client X11 program on your CentOS 6.6 server over SSH and displaying through the X11 server on your Mint 18 machine

that makes sense. I found a couple of items that mentioned how to enable iglx on the client side. I tried the Ubuntu method of adding Option “AllowIndirectGLXProtocol” “true” but nothing changed. I then tried the method from a Centos setup doing –

mv /usr/bin/Xorg /usr/bin/Xorg.original
echo -e ‘#!/usr/bin/env bash\nexec /usr/bin/Xorg.original “$@” +iglx’ > /usr/bin/Xorg
chmod +x /usr/bin/Xorg

After a reboot, it started working. I still get 2 errors when I launch the program over X. I get –
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

but the program still runs. I checked the links and all seems to be in place pointing to the nvidia libGL libraries. I’m not going to worry about it too much now since the program appears to be working. I’ll mark the original answer as accepted. Thank you for all of your help.

I’m assuming you’re running the client X11 program on your CentOS 6.6 server over SSH and displaying through the X11 server on your Mint 18 machine

that makes sense. I found a couple of items that mentioned how to enable iglx on the client side. I tried the Ubuntu method of adding Option “AllowIndirectGLXProtocol” “true” but nothing changed. I then tried the method from a Centos setup doing –

mv /usr/bin/Xorg /usr/bin/Xorg.original
echo -e ‘#!/usr/bin/env bash\nexec /usr/bin/Xorg.original “$@” +iglx’ > /usr/bin/Xorg
chmod +x /usr/bin/Xorg

After a reboot, it started working. I still get 2 errors when I launch the program over X. I get –
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

but the program still runs. I checked the links and all seems to be in place pointing to the nvidia libGL libraries. I’m not going to worry about it too much now since the program appears to be working. I’ll mark the original answer as accepted. Thank you for all of your help.