Modify Partition Table


My goal is to be able to create extra partitions by modifying the “flash_l4t_nvme_rootfs_ab.xml” file, and running the command:

sudo ROOTFS_AB=1 ./tools/kernel_flash/ \
      --external-device nvme0n1 \
      -c ./tools/kernel_flash/flash_l4t_nvme_rootfs_ab.xml \
      -S 40GiB  --showlogs \
      jetson-xavier-nx-devkit-emmc external

I added this field to the default file above the UDA partition:

	<partition name="my_new_partition" type="data">
          <allocation_policy> sequential </allocation_policy>
          <filesystem_type> basic </filesystem_type>
          <size> 10000000000 </size>
          <file_system_attribute> 0 </file_system_attribute>
          <allocation_attribute> 0x8 </allocation_attribute>
          <percent_reserved> 0 </percent_reserved>
          <description> For use by a customer </description>

This flashed successfully, and a lsusb command confirms that the partition was successfully created on nvme0n1p11.

nvme0n1      259:0    0   477G  0 disk 
├─nvme0n1p1  259:1    0    40G  0 part /
├─nvme0n1p2  259:2    0    40G  0 part 
├─nvme0n1p3  259:3    0    64M  0 part 
├─nvme0n1p4  259:4    0    64M  0 part 
├─nvme0n1p5  259:5    0   448K  0 part 
├─nvme0n1p6  259:6    0   448K  0 part 
├─nvme0n1p7  259:7    0    80M  0 part 
├─nvme0n1p8  259:8    0   512K  0 part 
├─nvme0n1p9  259:9    0   100M  0 part 
├─nvme0n1p10 259:10   0    64M  0 part 
├─nvme0n1p11 259:11   0   9.3G  0 part 
└─nvme0n1p12 259:12   0 387.3G  0 part 

I tried to mount it via this command sudo mount /dev/nvme0n1p11 /mnt/test/, but received the following error:

NTFS signature is missing.
Failed to mount '/dev/nvme0n1p11': Invalid argument
The device '/dev/nvme0n1p11' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

What changes do I need to make to “flash_l4t_nvme_rootfs_ab.xml” to make this a valid NTFS?

Hi chh,

Could you try the following command to mount it as nfts?

$ mount -t ntfs /dev/nvme0n1p11 /mnt/test

Or use mkntfs to format it:

$ sudo mkntfs -f /dev/nvme0n1p11

Please also help to provide the result of the following command on your board.

$ ls -al /dev/disk/by-partlabel

Hi KevinFFF,

Thanks for your response, a variant of that command worked for me:

sudo mkfs -t ext4 /dev/nvme0n1p11
sudo mount -t ext4 /dev/nvme0n1p11 /mnt/test

Is it possible to achieve this in the .xml file? I tried changing the line for my partitions to this.

<filesystem_type> ext4 </filesystem_type>

However inspection of the disk using gparted still indicated that the filesystem was unknown. Do you know how/why the APP and APP_b partitions are correctly formatted to ext4 and mine aren’t?

I think the default basic filesystem_type is similar as ext4.

Could you help to provide current flash_l4t_nvme_rootfs_ab.xml for further check?
and also the flash log from host side.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.