Modifying flash_l4t_external.xml for 1TB external NVME and additional user partition

So you still didn’t get the extra partition you wanted, right?

Please wait for this.

It failed, I think with different error.

The command:

sudo ./tools/kernel_flash/ --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external_1TB.xml -S 256 GiB -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 jetson-orin-nano-devkit external > flash_1TB_layout.log 2>&1

flash log:
flash_1TB_layout.log (129.4 KB)

The xml:
flash_l4t_external_1TB.xml (9.7 KB)

Yeah, didn’t get any changes using my layout.


I’m sorry that the error is caused by the space between 256 and GiB.
For the config file, please try changing from this

<device type="nvme" instance="0" sector_size="512" num_sectors="2147483648">

to this

<device type="external" instance="0" sector_size="512" num_sectors="2147483648">

The original already had the device_type=“external” property.

flashing failed (something is wrong with the numbers)

My command:

sudo ./tools/kernel_flash/ --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external_1TB.xml -S 256GiB -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 jetson-orin-nano-devkit external > flash_1TB_layout.log 2>&1

flash_l4t_external_1TB.xml (9.7 KB)

flash log:

flash_1TB_layout.log (252.0 KB)

Are you sure it’s exactly 2147483648?
Normally you’d try something smaller, like we only use 57GB for a 64GB drive by default.

Yes, so I don’t know how you got the idea to change it to nvme.

  1. I got the idea from here:
    Partition Configuration — Jetson Linux Developer Guide documentation

  2. The calculation I made is 512 * 2147483648 = 1099511627776 = 1024 * 1024 * 1024 * 1024 = 1TB

  3. I tried now with 900GB (num_sectors=1887436800) and it still fails:
    flash_1TB_layout.log (280.1 KB)


can you show the serial console log during flashing here?
flashing log does not help much.

Or try again with a different NVMe drive.

Yes, thank you.
uart.log (134.6 KB)

flash_l4t_external_1TB.xml (9.7 KB)

Unfortunately I don’t have another NVMe drive.

Have you tried pre-formatting the NVMe drive into ext4 before flashing?
Also, what do you get with the default layout file, and also without specifying the -S option?
Will it succeed? I need both flashing log and serial console log.

Your device just got stuck in initrd, and nothing was flashed into the SSD.
I do think there’s some issue about the NVMe drive.

  1. I didn’t pre-formatted the NVMe
  2. without specifying the -S flag + default layouts (any of them including A/B rootFS) everything works fine.

You want me to flash with default layout without -S flag and send the logs?

Then please just try pre-formatting the SSD.

can i do it from the devkit itself? maybe plug ubuntu rescue usb and format it?

I don’t think a Ubuntu rescue USB would work.
You can flash and boot from a USB drive, and do the operation on it.

Hi, can you help me please how to flash external usb?

I tried the following command:

sudo ./tools/kernel_flash/ --external-device sda1 -c ./tools/kernel_flash/flash_l4t_external.xml --showlogs jetson-orin-nano-devkit external

but it failed.
(I made sure the usb drive is formatted and has the sda1 partition)

Please try this as specified in our developer guide:

sudo ./tools/kernel_flash/ --external-device sda1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 jetson-orin-nano-devkit internal

it fails as well.

by the way, regarding flashing with default layout + -S flag, I flashed twice one after the other. with the -S flag it failed and without it it succeeded. You still think there is a problem in the NVMe drive that we need to format it?

I will check on my side and see whether the command (-S along with changing num_sectors) works.

I did the following:

copied the rootfs content into the usb partition, edited extlinux.conf on the nvme and now the system boots with the rootfs on the usb (workaround)

so now I can format the nvme as you said. do you have specific instructions regarding the nvme formating?

GNOME Disks should be enough.