ModuleNotFoundError: No module named Jetson in Python3.8 virtual environment

Hi, would love to ask for insights about this.

So I have already integrated BNO055 to my jetson nano in sudo installations.
I have run codes and imported the libraries, adafruit_bno055, board, and busio.

Well, today I tried creating a Python3.8 virtual environment for my other application. In the vEnv, I installed the bno055 by writing out
pip3 install adafruit_circuitpython-bno055 – this is the only installation for the bno055. I used this for the sudo, too
I was able to import adafruit_bno055, the only problem is that when it comes to import board and import busio, I get this error of no Module Named Jetson as shown in the picture below.

To note, i’m using Python3.8 because I need to incorporate this one with YoloV8

Hi johnmel.bolaybolay,

Are you using the devkit or custom board for Jetson Nano?
What’s your Jetpack version in use?

Have you referred to every steps in the following instruction for setup?
GitHub - NVIDIA/jetson-gpio: A Python library that enables the use of Jetson’s GPIOs

1 Like

Hi, solved this one by going to the root cause.
I went to the file of my virtual environment.
I somehow changed the import to **import Jetson.GPIO as GPIO
then i did pip3 install Jetson.GPIO in the venv.

then just typed these commands to allow usage of the library

  • Sudo usermod -aG gpio
  • Sudo chown root.gpio /dev/gpiochip0
  • Sudo chmod 660 /dev/gpiochip0
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.