Multicast stream between Windows and Ubuntu Machine

Hi. We want to udp multistream using Gstreamer (udpsink).
g_object_set(G_OBJECT(updsink), “host”, “”, NULL);
g_object_set(G_OBJECT(updsink), “auto-multicast”, TRUE, NULL);
when we enable auto-multicast as true, the system raises the error below;
Error: Could not/set settings from/on resource.

when we disable it, the program runs perfectly but we cannot get the stream.

Also, I’m trying to catch the same multicast stream from an ubuntu machine to a windows machine. The code runs on ubuntu and it starts a multicast stream using a camera source and the system uses Gstreamer. udpsink host is and the port 11002. the stream starts on ubuntu but we can not get it from windows whose ip configuration is given below;

ip address:

also ubuntu machine ip cfg is shown below:

ip address:

any help would be really appreciated. we just want to get the udp multicast stream from the ubuntu machine to windows machine.

This looks advancing and would need other users to share experience.

FYR. There are topics about basic UDP streaming:
Gstreamer TCPserversink 2-3 seconds latency - #5 by DaneLLL
Gstreamer TCPserversink 2-3 seconds latency - #13 by Bazziil
Nvv4l2decoder sometimes fails to negotiate with downstream after several pipeline re-launches - #16 by DaneLLL

The only help topics I saw were for machines receiving multicast. I didn’t have much success searching for multicast from the host broadcasting point of view. For the systems using multicast the gist is that some NICs support a different number of multicast groups they can be part of, and it will fail if using too many, but this is different from the host source of multicast error. Not quite sure what to say as I’m not familiar enough with multicast to say for sure without seeing someone else’s experience on setting up a host to broadcast. It does seem possible though that from the listening side issue responses that perhaps broadcasting multicast has some requirement of the NIC and/or driver too. If you can make this work without the “auto-multicast”, then perhaps you can set up a boot script to set this up or get help from the maintainers of the software with the “auto-multicast” in it.

You may also try changing TRUE to true (don’t use capitals).

I solved the problem, there were changes in the boardcast address, interestingly, the broadcast address of tx2 appears to be When I spread it on this tape, I was able to capture images in both windows and tx2. Thank you for your interest.
" sudo ifconfig eth0"

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.