Nano B01 crashes while installing PyTorch

My nano crashes and reboots by itself while installing Pytorch.

(I have tried more than 5 times. The result is always same.
(I also flashed my SD Card three times. Then I spent long hours to follow the installation and examples to reach the same point.)

Nano crashed and rebooted without any trace. Thus, I don’t have any trace to show you except what I did:

cd jetson-inference/build ./install-pytorch.sh

From the page,
Page;

Yes, I read one discussion, and using an argument for the installation script. (Although the person’s issue was not caching, but not being able to install. Anyway, I have tried, but it does not make any difference.)

I have also tried

PyTorch for Jetson Nano - version 1.5.0 now available

Same result did I got!

I am at the verge of quitting. Please help me.
Without passing this step, I cannot follow the re-training example.

Thanks!

I was able to make it work.
It could be one of many things, but here is what I did in case for someone like me in future:

  1. Flash SD card for Nano
  2. Initial Ubuntu setup
  3. Just do Quick Reference:in Building the Project from Source page
    https://github.com/dusty-nv/jetson-inference/blob/master/docs/building-repo-2.md
    sudo apt-get update sudo apt-get install git cmake libpython3-dev python3-numpy
    git clone --recursive https://github.com/dusty-nv/jetson-inference cd jetson-inference
    mkdir build cd build
    cmake ../ make -j$(nproc)
    sudo make install sudo ldconfig

Then move on to the next page (Classifying Images with ImageNet)

Just follow the examples or just move to the Transfer Learning with PyTorch page.

I have tried twice. It is repeatable. Thus, I am sharing this.

Thanks!