nccl 2.0 installation error

Hi,

I’m install nccl2.0 by following the steps in http://docs.nvidia.com/deeplearning/sdk/nccl-install-guide/index.html#down on my workstation with 4 Titan Xp cards and Ubuntu 14.04. I’ve installed cuda-8.0 and running ./deviceQuery it shows:

CUDA Driver = CUDART, CUDA Driver Version = 8.0, CUDA Runtime Version = 8.0, NumDevs = 4, Device0 = TITAN Xp, Device1 = TITAN Xp, Device2 = TITAN Xp, Device3 = TITAN Xp
Result = PASS

But when I install libnccl2.0, it shows:

[i]Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libnccl2 : Depends: cuda-cudart-8-0 but it is not installable
E: Unable to correct problems, you have held broken packages.[/i]

I’m not sure why such reason happens. May I know how to resolve this issue? Thanks!

BTW, when running cat /proc/driver/nvidia/version, it shows:

NVRM version: NVIDIA UNIX x86_64 Kernel Module 375.66 Mon May 1 15:29:16 PDT 2017
GCC version: gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3)

Best,
Fei

+1

Found the answer here: https://groups.google.com/a/tensorflow.org/forum/#!topic/discuss/NNifPbAMPRg