Netcdf 4.1.3 and PGI 12.9 (Mac OsX 10.8.2 M. Lion)

Hi all,

I’m trying to build netcdf-4.1.3 against PGI compilers with the following flags:

export CC=pgcc
export CXX=pgcpp
export FC=pgfortran
export LD=pgfortran
export CFLAGS="-fastsse -Msignextend"
export FFLAGS="-fastsse"
export CPPFLAGS="-DpgiFortran"
./configure --prefix=/Users/lcana/Lib/netcdf --disable-dap --disable-netcdf-4
make
make test
make install

Once started to do ‘make’, I see tons of warnings like this one:
“PGC-W-0267-#warning – “Unsupported compiler detected” (/usr/include/sys/cdefs.h: 81)
PGC-W-0114-More than one type specified (…/include/ncdispatch.h: 111)
PGC-W-0143-Useless typedef declaration (no declarators present) (…/include/ncdispatch.h: 111)”

And finally, compilation fails at this point:
libtool: compile: pgcc -DHAVE_CONFIG_H -I. -I… -I…/fortran -I…/include -DpgiFortran -fastsse -Msignextend -c ncx.c -o libnetcdf3_la-ncx.o
PGC-W-0267-#warning – “Unsupported compiler detected” (/usr/include/sys/cdefs.h: 81)
PGC-F-0249-#error – “ix_float implementation” (ncx.c: 1382)
PGC/x86-64 OSX 12.9-0: compilation aborted
make[2]: *** [libnetcdf3_la-ncx.lo] Error 1

Any idea?
Regards,

Luis

Luis,

I have sent you mail to address these problems.

After replacing the cdefs.h file in our include/sys area,
things build.

dave

Hello,

I am encountering this same error when trying to build netcdf-3.6.3 with PGI 12.10 (64bit) on CentOS 6.3 x86_64.

Would an update to that same file work for my issue? I followed the suggestions on the NetCDF363/PGI2012 web page, but had no further success.

source=‘attr.c’ object=‘attr.lo’ libtool=yes
DEPDIR=.deps depmode=none /bin/sh …/depcomp
/bin/sh …/libtool --tag=CC --mode=compile pgcc -DHAVE_CONFIG_H -I. -I… -I…/fortran -DNDEBUG -DpgiFortran -fast -Msignextend -Mipa=fast -c -o attr.lo attr.c
libtool: compile: pgcc -DHAVE_CONFIG_H -I. -I… -I…/fortran -DNDEBUG -DpgiFortran -fast -Msignextend -Mipa=fast -c attr.c -o attr.o
source=‘ncx.c’ object=‘ncx.lo’ libtool=yes
DEPDIR=.deps depmode=none /bin/sh …/depcomp
/bin/sh …/libtool --tag=CC --mode=compile pgcc -DHAVE_CONFIG_H -I. -I… -I…/fortran -DNDEBUG -DpgiFortran -fast -Msignextend -Mipa=fast -c -o ncx.lo ncx.c
libtool: compile: pgcc -DHAVE_CONFIG_H -I. -I… -I…/fortran -DNDEBUG -DpgiFortran -fast -Msignextend -Mipa=fast -c ncx.c -o ncx.o
PGC-F-0249-#error – “ix_float implementation” (ncx.c: 1240)
PGC/x86-64 Linux 12.10-0: compilation aborted
make[3]: *** [ncx.lo] Error 1
make[3]: Leaving directory /usr/local/src/netcdf-3.6.3/libsrc' make[2]: *** [all] Error 2 make[2]: Leaving directory /usr/local/src/netcdf-3.6.3/libsrc’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/netcdf-3.6.3’
make: *** [all] Error 2

Thank you,

Carter

I just encountered this as well.

It looks like you guys have a fix for this (comments above discuss ‘sending a file’ to other folks reporting this). How does one go about getting the file.

Could we post it somewhere and link to it?

Or can I get you to send me a copy of the proposed fix.

Gary

Hi Gary,

Send a note to PGI Customer Service (trs@pgroup.com).

Thanks,
Mat

Thanks Matt - I received the file almost immediately.

In case anyone else hits this, after updating cdefs.h I hit one more snag

pgaccelinfo -v

Complained that libcuda.dylib could not be found.

CUDA5.0 does not have this file :)

After some ‘poking around’ I found that by linking

ln libcuda.dylib libcuinj_50_36.dylib

In /Developer/NVIDIA/CUDA-5.0/lib

Everything worked like a charm.

Thanks