New driver hangs computer, older one dosn't work properly

As of version (about) 331.20 to current 340.76 the driver do hands probably my GPU. In fact computer hangs after several minutes of work ultimately, no message, no log, shows smashed last picture on monitor and only reset helps. No, I don’t think this is because on overheating (other versions shows same temperature of about 65 Celsius).

Quite old version 319.82 worked fine but currently I can’t find a way to compile modern kernel module.

Version 304.125 works quite well, but shows a lot of problem with GLX, saying

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

Even nvidia-settings crashes when trying to open OpenGL/GLX information tab, saying

The error was ‘BadValue (integer parameter out of range for operation)’.
(Details: serial 479 error_code 2 request_code 153 minor_code 3)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

Using Fedora 22, the problem appeared in fact before Fedora 20, and no fixes since that time despite many driver updates.

$ lspci | grep VGA
02:00.0 VGA compatible controller: NVIDIA Corporation C77 [GeForce 8300] (rev a2)

$ cat /var/log/Xorg.0.log | grep glx
[ 4045.417] (II) “glx” will be loaded by default.
[ 4045.417] (II) LoadModule: “glx”
[ 4045.417] (II) Loading /usr/lib64/xorg/modules/nvidia-304xx-304.125/libglx.so
[ 4045.572] (II) Module glx: vendor=“NVIDIA Corporation”

$ glxinfo
name of display: :0.0
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: GLXBadContext
Major opcode of failed request: 153 (GLX)
Minor opcode of failed request: 6 (X_GLXIsDirect)
Serial number of failed request: 46
Current serial number in output stream: 45

$ inxi -G
Graphics: Card: NVIDIA C77 [GeForce 8300]
Display Server: Fedora X.org 117.1 driver: nvidia Resolution: 1280x1024@75.02hz
GLX Renderer: N/A GLX Version: N/A

Never (340xx) version is quite hard to test since it hands too quickly after boot.

Using onboard video card showed as C77 [GeForce 8300] [10DE:848] on ASUS M3N78 PROmotherboard. However PCI Bridge is MCP78S [GeForce 8200] PCI Express Bridge [10DE:569].
nvidia-bug-report.log.gz (87.4 KB)

Please follow the steps here:
https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

And attach the bugreport.

Sorry, I’ve attached report.

However.

Report was created as root, but it looks like root can use glx, so not sure if will show anything.

And I’m not sure if I can make such a report for newer (hanging) driver.

Still no way to fix?
I’m afraid 304xx branch will be dropped as an old one too soon and 340xx would not work either…