no CUDA-capable device is detected

I am trying to run an application using GPU. I have setup all settings and drivers. My OS is Ubuntu14.04 LTS.

I checked whether I have CUDA capable device like

lspci | grep -i nvidia
05:00.0 VGA compatible controller: NVIDIA Corporation GK107GL [Quadro K2000] (rev a1)
05:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

My nvcc -V check gave me

li@li-HP-Z420-Workstation:/dev$ nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2015 NVIDIA Corporation
Built on Tue_Aug_11_14:27:32_CDT_2015
Cuda compilation tools, release 7.5, V7.5.17

Then my version check

li@li-HP-Z420-Workstation:/dev$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 352.41 Fri Aug 21 23:09:52 PDT 2015
GCC version: gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04)

I checked in the dev/ folder, I have nvidia0.

crwxrwxrwx 1 root root 195, 0 Sep 10 16:51 nvidia0
crw-rw-rw- 1 root root 195, 255 Sep 10 16:51 nvidiactl

When I run ./deviceQuery

…/NVIDIA_CUDA-7.5_Samples/bin/x86_64/linux/release/deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL

Then I run
ln@ln-HP-Z420-Workstation:/$ nvidia-smi -a

==============NVSMI LOG==============

Timestamp : Thu Sep 10 18:59:29 2015
Driver Version : 352.41

Attached GPUs : 1
GPU 0000:05:00.0
Product Name : Quadro K2000
Product Brand : Quadro
Display Mode : Enabled
Display Active : Enabled
Persistence Mode : Disabled
Accounting Mode : Disabled
Accounting Mode Buffer Size : 1920
Driver Model
Current : N/A
Pending : N/A
Serial Number : 0323413053374
GPU UUID : GPU-caf26082-102c-ef43-8e39-f162fdcaa716
Minor Number : 0
VBIOS Version : 80.07.9B.00.07
MultiGPU Board : No
Board ID : 0x500
Inforom Version
Image Version : 2095.0500.00.01
OEM Object : 1.1
ECC Object : N/A
Power Management Object : N/A
GPU Operation Mode
Current : N/A
Pending : N/A
PCI
Bus : 0x05
Device : 0x00
Domain : 0x0000
Device Id : 0x0FFE10DE
Bus Id : 0000:05:00.0
Sub System Id : 0x094C103C
GPU Link Info
PCIe Generation
Max : 2
Current : 1
Link Width
Max : 16x
Current : 16x
Bridge Chip
Type : N/A
Firmware : N/A
Replays since reset : 0
Tx Throughput : N/A
Rx Throughput : N/A
Fan Speed : 30 %
Performance State : P8
Clocks Throttle Reasons
Idle : Active
Applications Clocks Setting : Not Active
SW Power Cap : Not Active
HW Slowdown : Not Active
Unknown : Not Active
FB Memory Usage
Total : 2047 MiB
Used : 227 MiB
Free : 1820 MiB
BAR1 Memory Usage
Total : 256 MiB
Used : 4 MiB
Free : 252 MiB
Compute Mode : Default
Utilization
Gpu : 0 %
Memory : 6 %
Encoder : 0 %
Decoder : 0 %
Ecc Mode
Current : N/A
Pending : N/A
ECC Errors
Volatile
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Aggregate
Single Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Double Bit
Device Memory : N/A
Register File : N/A
L1 Cache : N/A
L2 Cache : N/A
Texture Memory : N/A
Total : N/A
Retired Pages
Single Bit ECC : N/A
Double Bit ECC : N/A
Pending : N/A
Temperature
GPU Current Temp : 31 C
GPU Shutdown Temp : 103 C
GPU Slowdown Temp : 98 C
Power Readings
Power Management : N/A
Power Draw : N/A
Power Limit : N/A
Default Power Limit : N/A
Enforced Power Limit : N/A
Min Power Limit : N/A
Max Power Limit : N/A
Clocks
Graphics : 324 MHz
SM : 324 MHz
Memory : 324 MHz
Applications Clocks
Graphics : N/A
Memory : N/A
Default Applications Clocks
Graphics : N/A
Memory : N/A
Max Clocks
Graphics : 954 MHz
SM : 954 MHz
Memory : 2000 MHz
Clock Policy
Auto Boost : N/A
Auto Boost Default : N/A
Processes
Process ID : 1263
Type : G
Name : /usr/bin/X
Used GPU Memory : 159 MiB
Process ID : 2057
Type : G
Name : compiz
Used GPU Memory : 58 MiB

What could be wrong with this?
Thanks

It’s likely that you installed CUDA via the package manager method and did it incorrectly, so that your driver install is incomplete.

You might want to follow the instructions in the linux getting started guide carefully:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#abstract

Or else describe exactly how you installed CUDA, and exactly how you installed that 352.41 driver.

Also, after running the deviceQuery command that failed, get the output of:

sudo dmesg |grep NVRM

and paste it here.

I used the following commands for CUDA installation.

sudo dpkg -i cuda-repo-ubuntu1404-7-5-local_7.5-18_amd64.deb
sudo apt-get update
sudo apt-get install cuda
This is the first time installation of CUDA for this PC.

For the driver, I used
sudo add-apt-repository ppa:xorg-edgers/ppa -y sudo apt-get update
$ sudo apt-get install nvidia-352

Yeah I’ll check when I get back to office. It is not Ubuntu14.04 and CUDA7.0 version issue? I am thinking to retry with CUDA6.5.

I don’t find those driver install steps in the document I linked. So I think your driver install is broken. I suggest just following the document I linked.

Note what it says in the document I linked:

"The cuda package installs all the available packages for native developments. That includes the compiler, the debugger, the profiler, the math libraries,… For x86_64 patforms, this also include NSight Eclipse Edition and the visual profiler It also includes the NVIDIA driver package "

In other words, the cuda package is all you need, and the steps in the document I linked should be followed exactly. When you decided to load the 352 driver using an undocumented sequence, you broke your setup.

Please follow the directions in the document I linked. You may need to start over with a clean install of ubuntu.

If you do wish to upgrade the driver only, beyond the one that you get with the cuda package, the proper method is also spelled out in the document:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#package-manager-upgrades

I am using NVIDIA Tegra TK1 Kit. I am using two computer one is Host running with Linux OS and another is Tegra connected computer. I have started the kit and installed JetPack in Tegra kit using Host computer. I dont know whether I have installed all the drivers correctly or not.
When I am running the code into Tegra connected computer ubuntu terminal I got these output
lspci | grep -i nvidia
00:00.0 PCI bridge: NVIDIA Corporation Tegra K1 PCIe x1 Bridgwe(rev a1)

nvcc --version:
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2014 NVIDIA Corporation
Built on Tue_Feb_17_22:42:19_CST_2015
Cuda compilation tools, release 6.5, V6.5.45
csio-javed@csiojaved-OptiPlex-9020:~$

I am trying to run CUDA sample program using NSIGHT Eclipse Edition v6.5 with host computer. It shows no cuda compatible device is detected. Every time it show Error while i Debug the program. Please tell me how Can I fix this problem and how can I compile CUDA sample program using nsight.
Please refer me any video lecture or document so easily I can fix my problem.
Thank you

remember to have a restart to make some of your installations take effect

restart make it work!!