No display from RTX 6000 Ada

I am unable to get a display from my RTX 6000 Ada. The GPU has been tested and works in another system. I am able to get a display using integrated graphics, so I installed Ubuntu and ran and it seems like I am getting the error NVRM: RTX 6000 Ada PCI I/O region assigned to NVIDIA device is invalid

OS: Ubuntu 22.04 Server kernel version 5.15.0-67-generic
CPU: AMD Ryzen 9 7950X
GPU: RTX 6000 Ada in a PCIE x 16 slot, but it appears to be running in x8
Storage: 2 1TB Gen 5 m.2s installed in x8 slots that appear to be running in x4
Motherboard: MSI MEG X670E Ace
Bios Version: E7DD69AMS.150
Bios Build Date: 01/18/2023

BIOS settings:
Secure Boot is disabled
Re-size BAR Support is enabled
Above 4G memory/Crypto Currency Mining is enabled

Things tried:
Placed the GPU in another system, which worked.

RMA’d the motherboard because it was having the same problem not being able to display from the GPU.

Uninstalling nvidia, libnvidia, and cuda. Then trying to reinstall CUDA toolkit 12.1 from local deb.

Setting pci=realloc=off in grub. After doing this the computer infinitely prints NVRM: PCI I/O region assigned to NVIDIA device is invalid and I’m unable to access the PC unless I ssh into it.

Current error log:
nvidia-bug-report.log (3.0 MB)

Please uninstall the nvidia driver, remove any additional kernel parameters you set, then provide a dmesg output after reboot.

I reverted my kernel and rebuilt grub then purged all nvidia, libnvidia, and cuda packages. Here’s my dmesg output:
dmesg_output.txt (108.2 KB)

Ok, 64bit resources are enabled but BAR 0 can’t be assigned. Please set kernel parameter
and provide a new dmesg output
don’t install the driver yet.

I set GRUB_CMDLINE_LINUX_DEFAULT=“pci=realloc” Is this the correct way to set it?
Here’s the new dmesg:
pci_realloc_dmesg_output.txt (112.4 KB)

The parameter is correctly set but doesn’t have any influence. Since you already tried pci=realloc=off without success, please try
and create a new dmesg output.

Did the above. Here’s the output:
crs_dmesg_output.txt (112.5 KB)

No luck. Last thing to try would be
If that also doesn’work, you might check if upgrading the kernel to latest using the liquorix ppa helps. Otherwise, you can only report a kernel bug since it doesn’t want to drive a RTX 6000 Ada in that mainboard.
pci 0000:01:00.0: BAR 0: no space for [mem size 0x01000000]

The available bridge resources should be sufficent, 16MB wanted and at least 256MB free.

nocrs_dmesg_output.txt (105.6 KB)

Nope, no luck. I guess you should reach out to MSI support to maybe get a fixed bios.

Ok, I’ll try that. Thanks for your help.